Bug 727966 - RFE: Don't lookup system $releasever when preconf.releasever is set.
Summary: RFE: Don't lookup system $releasever when preconf.releasever is set.
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: yum
Version: 16
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: ---
Assignee: Seth Vidal
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-08-03 19:29 UTC by Clyde E. Kunkel
Modified: 2014-01-21 23:18 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-12-02 15:47:27 UTC


Attachments (Terms of Use)
anaconda log of traceback (77.88 KB, text/plain)
2011-08-03 19:29 UTC, Clyde E. Kunkel
no flags Details
anaconda-tb-* as requested (3.25 MB, text/plain)
2011-08-04 16:56 UTC, Clyde E. Kunkel
no flags Details

Description Clyde E. Kunkel 2011-08-03 19:29:16 UTC
Created attachment 516566 [details]
anaconda log of traceback

Description of problem:
traceback after specifying boot loader location

Version-Release number of selected component (if applicable):
16.14 with updates

How reproducible:
didn't try

Steps to Reproduce:
1. boot tc1 and use updates.img from http://clumens.fedorapeople.org/723167.img
2. select custom layout
3. specify boot loader location, click next
  
Actual results:
traceback

Expected results:
continue on to installation

Additional info:
This is probably related to https://bugzilla.redhat.com/show_bug.cgi?id=723167

Comment 1 Chris Lumens 2011-08-04 14:59:33 UTC
Can you grab /tmp/anaconda-tb-* and attach to this bug report?  Thanks.

Comment 2 Clyde E. Kunkel 2011-08-04 16:56:01 UTC
Created attachment 516747 [details]
anaconda-tb-* as requested

Deleted original, reran install attempt and got same error, so hope this file serves your purpose.

Regards,
OldFart

Comment 3 Clyde E. Kunkel 2011-08-04 16:57:04 UTC
By chance is "Cannot connect to Gnome Keyring Daemon" related?

Comment 4 Chris Lumens 2011-08-04 19:13:57 UTC
That should only be a problem with saving bugs automatically.  It shouldn't be causing the traceback.

Comment 5 Clyde E. Kunkel 2011-08-09 21:12:15 UTC
problem persists in 16.14.2 and 16.14.3

Comment 6 Clyde E. Kunkel 2011-08-11 14:20:53 UTC
hi, shouldn't this bz be an alpha blocker?

Comment 7 Clyde E. Kunkel 2011-08-16 01:38:57 UTC
Still not fixed in 16.14-1

Comment 8 Chris Lumens 2011-08-16 15:19:18 UTC
anaconda sets up releasever before _getConfig is called specifically because there's not going to be a system-release package installed to be read.  See around line 776 in yuminstall.py (doConfigSetup).  I don't know why yum would be trying to set it anyway.

Comment 9 James Antill 2011-08-17 15:48:56 UTC
> anaconda sets up releasever before _getConfig is called specifically because
> there's not going to be a system-release package installed to be read.  See
> around line 776 in yuminstall.py (doConfigSetup).  I don't know why yum would
> be trying to set it anyway.

 AFAIK we've always done that ... we always look for the system releasever, and then override it with the preconf/etc. one. We can fix that, I guess, it will mean adding a parameter to readStartupConfig() ... which I think will be fine.

 Normally this just meant that no package was found, and releasever='$releasever', maybe rpm has started complaining in cases were it didn't before?

Comment 10 Clyde E. Kunkel 2011-08-17 16:21:58 UTC
(In reply to comment #9)
><snip>
> 
>  Normally this just meant that no package was found, and
> releasever='$releasever', maybe rpm has started complaining in cases were it
> didn't before?

Could this be due to the trailing slash bug of rpm-4.9.1?

Comment 11 James Antill 2011-08-17 19:30:47 UTC
AFAIK that was an rpmbuild bug only.

Comment 12 Panu Matilainen 2011-08-18 04:53:54 UTC
It was rpmbuild-only bug that affected some directories, nothing else. So it would be possible to fail looking for a provider of /some/directory where a buggy rpm contains /some/directory/ but that's not the case with releasever lookup AFAIK.

Comment 13 Clyde E. Kunkel 2011-12-02 15:47:27 UTC
Apparently fixed.....


Note You need to log in before you can comment on or make changes to this bug.