Bug 72797 - Python warning using redhat-config-nfs
Python warning using redhat-config-nfs
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: redhat-config-nfs (Show other bugs)
8.0
i386 Linux
medium Severity low
: ---
: ---
Assigned To: Brent Fox
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-08-27 18:10 EDT by Peter van Egdom
Modified: 2008-05-01 11:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-12-25 18:44:03 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Peter van Egdom 2002-08-27 18:10:10 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.1) Gecko/20020826

Description of problem:
When I use the file-manager in "redhat-config-nfs" (add --> browse), the
following error appears (when redhat-config-nfs is started from an xterm):

/usr/share/redhat-config-nfs/propertiesWindow.py:175:
DeprecationWarning: use GtkContainer.get_children
  dlg.children()[0].children()[3].children()[0].children()[1].hide()


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. start "redhat-config-nfs" from an xterm.
2. add --> browse
3.
	

Actual Results:  /usr/share/redhat-config-nfs/propertiesWindow.py:175:
DeprecationWarning: use GtkContainer.get_children
  dlg.children()[0].children()[3].children()[0].children()[1].hide()

Expected Results:  no python errors should appear...

Additional info:

redhat-config-nfs-1.0-1
Comment 1 Brent Fox 2002-08-27 20:38:37 EDT
Should be fixed in redhat-config-nfs-1.0.0-3

QA, please verify.
Comment 2 Peter van Egdom 2002-10-31 14:54:09 EST
Even worse, I cannot get "redhat-config-nfs" working on my system at all.

(redhat-config-nfs-1.0.1-3)

The other "redhat-config-" tools seem to work (apart from some non-fatal
gtk-errors) fine.


This is the output from "redhat-config-nfs" when started :

[root@nec root]# redhat-config-nfs        

(redhat-config-nfs.py:5260): Gtk-CRITICAL **: file gtkitemfactory.c: line 958
(gtk_item_factory_create_item): assertion `entry->path[0] == '/'' failed

(redhat-config-nfs.py:5260): Gtk-CRITICAL **: file gtkitemfactory.c: line 958
(gtk_item_factory_create_item): assertion `entry->path[0] == '/'' failed

(redhat-config-nfs.py:5260): Gtk-CRITICAL **: file gtkitemfactory.c: line 958
(gtk_item_factory_create_item): assertion `entry->path[0] == '/'' failed

(redhat-config-nfs.py:5260): Gtk-CRITICAL **: file gtkitemfactory.c: line 958
(gtk_item_factory_create_item): assertion `entry->path[0] == '/'' failed

(redhat-config-nfs.py:5260): Gtk-CRITICAL **: file gtkitemfactory.c: line 958
(gtk_item_factory_create_item): assertion `entry->path[0] == '/'' failed

(redhat-config-nfs.py:5260): Gtk-CRITICAL **: file gtkitemfactory.c: line 958
(gtk_item_factory_create_item): assertion `entry->path[0] == '/'' failed

(redhat-config-nfs.py:5260): Gtk-CRITICAL **: file gtkitemfactory.c: line 958
(gtk_item_factory_create_item): assertion `entry->path[0] == '/'' failed

(redhat-config-nfs.py:5260): Gtk-CRITICAL **: file gtkitemfactory.c: line 958
(gtk_item_factory_create_item): assertion `entry->path[0] == '/'' failed
Traceback (most recent call last):
  File "/usr/share/redhat-config-nfs/redhat-config-nfs.py", line 29, in ?
    mainWindow.mainWindow()
  File "/usr/share/redhat-config-nfs/mainWindow.py", line 114, in __init__
    self.actionMenu = self.menuBar.get_children()[0].get_submenu()        
IndexError: list index out of range
Comment 3 Brent Fox 2002-10-31 15:37:51 EST
I suspect that something is hosed with your GTK installation.  You should not be
seeing these assertion errors.  Those errors are causing the Action menu to be
empty, which causes the Python traceback.  The problem actually seems to be at
the GTK level now.  I recommend opening a new bug against GTK, but make sure you
are using the version that shipped in 8.0.
Comment 4 Peter van Egdom 2002-11-01 13:37:07 EST
I'm using a fresh installation of Red Hat Linux 8.0 Personal (shrink-wrapped \
&& crc-verified).

I'll open a bug against the gtk component.

Comment 5 Peter van Egdom 2002-12-25 18:44:03 EST
Seems to be fixed in redhat-config-nfs-1.0.2-2
(tested with Red Hat Linux release 8.0.92 (Phoebe)).

Thanks!

Note You need to log in before you can comment on or make changes to this bug.