Bug 727973 - Compliance Assistant Subscription Details Area Not Getting Cleared
Summary: Compliance Assistant Subscription Details Area Not Getting Cleared
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: subscription-manager
Version: 5.7
Hardware: Unspecified
OS: Unspecified
unspecified
low
Target Milestone: beta
: 5.8
Assignee: Devan Goodwin
QA Contact: John Sefler
URL:
Whiteboard:
Depends On:
Blocks: 715031
TreeView+ depends on / blocked
 
Reported: 2011-08-03 20:01 UTC by Devan Goodwin
Modified: 2012-02-21 06:31 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
No description necessary
Clone Of:
Environment:
Last Closed: 2012-02-21 06:31:14 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2012:0154 normal SHIPPED_LIVE subscription-manager bug fix update 2012-02-20 15:06:04 UTC

Description Devan Goodwin 2011-08-03 20:01:06 UTC
Description of problem:

The Subscription Details portion of the Compliance Assistant is not cleared across repeated calls to the Compliance Assistant.

Version-Release number of selected component (if applicable):

subscription-manager-0.96.5-1

How reproducible:

100%

Steps to Reproduce:
1. Open compliance assistant, select a product that will be out of compliance, then select one of the subscriptions that will satisfy it. (NOTE: you do not have to actually subscribe) 
2. Close compliance assistant.
3. Re-open compliance assistant.
  
Actual results:

The subscription details at the bottom of the screen are still there from the last one you viewed, even though now nothing is selected in the Subscription pane.


Expected results:

Details need to be cleared, similar to how the Subscription list is getting cleared.


Additional info:

Comment 3 Devan Goodwin 2011-11-10 19:01:12 UTC
Fixed in subscription-manager.git as of 72a919a6f2f0c6c33f6c39345b2a4036d76064b9. Will appear in subscription-manager-0.98.2-1.

Comment 5 J.C. Molet 2011-12-06 18:09:12 UTC
fix is VERIFIED against:

subscription-manager-0.98.5-1.git.2.cd86f84.el5_7
subscription-manager-firstboot-0.98.5-1.git.2.cd86f84.el5_7
subscription-manager-gnome-0.98.5-1.git.2.cd86f84.el5_7

When the subscription assistant is brought back up, it updates the subscription list and at that point clears the information that was previously showing.

Comment 6 William Poteat 2012-01-20 19:13:40 UTC
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
No description necessary

Comment 7 errata-xmlrpc 2012-02-21 06:31:14 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2012-0154.html


Note You need to log in before you can comment on or make changes to this bug.