Bug 727980 - Networking anomaly started in F15
Summary: Networking anomaly started in F15
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: NetworkManager
Version: 15
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Dan Williams
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-08-03 20:30 UTC by Jim Haynes
Modified: 2012-01-09 15:11 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-01-09 15:11:10 UTC


Attachments (Terms of Use)
output from ifconfig eth0 and dmesg | grep eth0 (1.25 KB, text/plain)
2011-08-03 20:32 UTC, Jim Haynes
no flags Details
file /var/log/messages (294.98 KB, text/plain)
2011-12-23 00:07 UTC, Adri Verhoef
no flags Details

Description Jim Haynes 2011-08-03 20:30:17 UTC
Description of problem:I have a workstation that is also a router between DSL
and the LAN here.  A second workstation that is on the LAN was just upgraded
to F15.

After the upgrade: firefox always comes up with the work offline box checked
but after I uncheck the box it works OK

                   trying to do Applications->System tools->Software update
results in "Gathering information" and then after a while it opens a box
saying "No updates are available  No network connection was detected."
However running yum update from a terminal works OK.

It didn't do this when the workstation was on F14.  It doesn't seem to
matter if the workstation acting as a router is running F14 or F15.  The
workstation with the problem is dual boot and under Windows XP seems to work
OK. 

I've attached the output from ifconfig on the eth0 interface and from
dmesg | grep eth0   on the affected workstation.  The LAN consists of a 
Linksys 8 port 10/100 workgroup switch.  


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

Comment 1 Jim Haynes 2011-08-03 20:32:25 UTC
Created attachment 516576 [details]
output from ifconfig eth0 and dmesg | grep eth0

Looks like the attachment didn't get attached to the original bug report.

Comment 2 Jirka Klimes 2011-09-08 13:38:52 UTC
Maybe NetworkManager is not enabled or running. Check:
$ systemctl is-enabled NetworkManager.service && echo "yes"
$ systemctl is-active NetworkManager.service

and possibly enable, run it with:
# systemctl enable NetworkManager.service && echo "yes"
# systemctl start NetworkManager.service

Also upgrade the system and NetworkManager packages.
Please attach /var/log/messages if the problem persist.

Comment 3 Jim Haynes 2011-09-09 19:26:30 UTC
Well I can't conveniently do that right now.  Because of that and so many
other problems I reverted to F14.  I can't verify that NetworkManager was
or was not running, but normally I don't run NetworkManager because that
machine runs with a fixed IP address so NetworkManager doesn't bring anything
to the party.

Comment 4 Adri Verhoef 2011-12-23 00:07:44 UTC
Created attachment 549256 [details]
file /var/log/messages

It seems that I have the same problem here.  The internet connection is OK, but "Software update" says "Getting information" shortly and then opens a box with "No updates are available - No network connection was detected."

I just upgraded from F14 to F15 and there are no updates available through "yum update" at this time, so the problem persists.

Output from running the following commands:
$ systemctl is-enabled NetworkManager.service && echo "yes"
yes
$ systemctl is-active NetworkManager.service
active
$ systemctl status NetworkManager.service
NetworkManager.service - Network Manager
	  Loaded: loaded (/lib/systemd/system/NetworkManager.service)
	  Active: active (running) since Thu, 22 Dec 2011 22:48:59 +0100; 2h 10min ago
	Main PID: 859 (NetworkManager)
	  CGroup: name=systemd:/system/NetworkManager.service
		  └ 859 /usr/sbin/NetworkManager --no-daemon

Please find the file /var/log/messages attached.

Comment 5 Jim Haynes 2011-12-23 02:05:56 UTC
I gave up on F15 and have since installed F16 dual boot with F14.
The problem doesn't appear to happen now that I'm on F16.

Comment 6 Adri Verhoef 2012-01-09 13:42:01 UTC
Still F15 here, but the problem has gone away.  In Compiz, I clicked "Software Update" in the Applications->System Tools menu, then a box opens with "Getting information" and then "There are 70 updates available" appears.

$ systemctl is-enabled NetworkManager.service && echo "yes"
yes
$ systemctl is-active NetworkManager.service
active
$ systemctl status NetworkManager.service
NetworkManager.service - Network Manager
	  Loaded: loaded (/lib/systemd/system/NetworkManager.service)
	  Active: active (running) since Fri, 06 Jan 2012 22:35:05 +0100; 2 days ago
	Main PID: 898 (NetworkManager)
	  CGroup: name=systemd:/system/NetworkManager.service
		  └ 898 /usr/sbin/NetworkManager --no-daemon

Actually, since then a lot of things have changed.

Situation: ('b' is my computer)

Internet <--> a <--> b

Before: 'a' ran F16 and 'b' ran F15.
After: 'a' now runs F15, 'b' still runs F15.

So the problem seems to be solved now.

Comment 7 Jirka Klimes 2012-01-09 15:11:10 UTC
Closing based on comments #5 and #6.


Note You need to log in before you can comment on or make changes to this bug.