Bug 72814 - Kerberos issues with openssh
Kerberos issues with openssh
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: openssh (Show other bugs)
8.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Nalin Dahyabhai
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-08-28 00:55 EDT by Stephen John Smoogen
Modified: 2007-04-18 12:46 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-12-30 15:04:48 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch from mailing list made to work with GSSAPI patch. (5.77 KB, text/plain)
2002-08-28 00:56 EDT, Stephen John Smoogen
no flags Details

  None (edit)
Description Stephen John Smoogen 2002-08-28 00:55:59 EDT
Description of Problem:

openssh-3.4p1 does not authorize via kerberos5 over ssh-1. This broke somewhere
between openssh-3.1p1 and openssh-3.4p1 in the upstream code.

Version-Release number of selected component (if applicable):

openssh-3.4p1-2

How Reproducible:

100%

Steps to Reproduce:
1. kinit -f
2. ssh -1 other_machine_running_ssh+krb5
3. watch for password to occur versus authentication

Additional Information:
	
We (LANL-> David Williams, Quellyn Snead, Stephen Smoogen) have applied the
patch mentioned on the openssh mailing list to try and fix the problem. Testing
this patch allows for us to authenticate via kerberos1.
Comment 1 Stephen John Smoogen 2002-08-28 00:56:52 EDT
Created attachment 73445 [details]
Patch from mailing list made to work with GSSAPI patch.
Comment 2 Stephen John Smoogen 2002-12-30 15:04:48 EST
The 3.5p1 release has this incorporated in it.

Note You need to log in before you can comment on or make changes to this bug.