Bug 728172 - anaconda failed to load a kickstart file from a file:// path
Summary: anaconda failed to load a kickstart file from a file:// path
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda
Version: 16
Hardware: All
OS: Linux
unspecified
unspecified
Target Milestone: ---
Assignee: Anaconda Maintenance Team
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-08-04 09:34 UTC by He Rui
Modified: 2011-08-08 13:53 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-08-08 13:53:07 UTC


Attachments (Terms of Use)
error.png (5.61 KB, image/png)
2011-08-04 09:34 UTC, He Rui
no flags Details
tmp.tar.gz (14.94 KB, application/x-tar)
2011-08-04 09:37 UTC, He Rui
no flags Details

Description He Rui 2011-08-04 09:34:19 UTC
Created attachment 516666 [details]
error.png

Description of problem:

Tested f16-alpha-tc1 by the case:

https://fedoraproject.org/wiki/QA:Testcase_Kickstart_File_Path_Ks_Cfg

However, anaconda failed to open/read kickstart file included in initrd.img


Version-Release number of selected component (if applicable):
anaconda 16.14
16 alpha tc1

How reproducible:
100%

Comment 1 He Rui 2011-08-04 09:37:19 UTC
Created attachment 516667 [details]
tmp.tar.gz

Comment 2 Chris Lumens 2011-08-04 16:04:03 UTC
Just to rule out two stupid possibilities:

(1) Does /ks.cfg really exist in the initrd?

(2) Does it work if you use ks=file:/ks.cfg?  Note the lack of extra slashes there.

Comment 3 He Rui 2011-08-05 03:43:02 UTC
(In reply to comment #2)
> Just to rule out two stupid possibilities:
> 
> (1) Does /ks.cfg really exist in the initrd?

How can I decompressed the F-16 initrd.img? "#xz --format=lzma initrd.img.xz --decompress" doesn't work for me. What I can see is the file size was increased after executing "#echo ks.cfg |cpio -c -o >> initrd.img". I uploaded the initrd.img which should contain the ks.cfg.

> 
> (2) Does it work if you use ks=file:/ks.cfg?  Note the lack of extra slashes
> there.

No, the result is the same.

Comment 4 He Rui 2011-08-05 03:47:02 UTC
(In reply to comment #3)
> (In reply to comment #2)
> > Just to rule out two stupid possibilities:
> > 
> > (1) Does /ks.cfg really exist in the initrd?
> 
> How can I decompressed the F-16 initrd.img? "#xz --format=lzma initrd.img.xz
> --decompress" doesn't work for me. What I can see is the file size was
> increased after executing "#echo ks.cfg |cpio -c -o >> initrd.img". I uploaded
> the initrd.img which should contain the ks.cfg.

Sorry, the size exceeded for uploading.

Comment 5 Chris Lumens 2011-08-05 14:03:59 UTC
Oh, I was just thinking that you could switch over to tty2 (which should always have a shell on it now) and verify that it exists.  No need to do anything too tricky.

Comment 6 He Rui 2011-08-08 05:25:29 UTC
(In reply to comment #5)
> Oh, I was just thinking that you could switch over to tty2 (which should always
> have a shell on it now) and verify that it exists.  No need to do anything too
> tricky.

No, there's no ks.cfg found. So it's not anaconda issue but the way "echo ks.cfg |cpio -c -o >> initrd.img" doesn't work?

Comment 7 Chris Lumens 2011-08-08 13:53:07 UTC
That's what it looks like to me.


Note You need to log in before you can comment on or make changes to this bug.