Bug 728206 - Change in clone job are not reflected in new job
Summary: Change in clone job are not reflected in new job
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Beaker
Classification: Community
Component: web UI
Version: 0.7
Hardware: x86_64
OS: Linux
high
urgent vote
Target Milestone: ---
Assignee: Raymond Mancy
QA Contact:
URL:
Whiteboard: MC
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-08-04 11:31 UTC by Kamil Kolakowski
Modified: 2014-12-08 01:09 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-10-10 06:14:24 UTC


Attachments (Terms of Use)

Description Kamil Kolakowski 2011-08-04 11:31:45 UTC
Description of problem:
If I will change priority from Urgent to High in editor - when I do clone job - this change is not reflected and priority of new job is still in Urgent. 

Version-Release number of selected component (if applicable):
present

How reproducible:
Do and submit job with priority Urgent. Then click on clone job. Change job priority from Urgent to High. Submit changed job.

And you will see that job is running with Urgent priority - and that is wrong.
 
Actual results:
Doesn't reflect changes I did in priority of job.

Expected results:
If I will rewrite priority with High value job should be run with High priority.

Additional info:
Ping me on IRC #brno if needed.

Comment 1 Kamil Kolakowski 2011-11-08 07:40:20 UTC
I tried the same issue on 2 beaker portals:

1./ 	https://beaker-stage-02.app.eng.bos.redhat.com
Even I choose priority High or Urgent always put into job description 
<recipeSet priority="Normal">
This happened with submitting new job from XML too.

2./ https://beaker.engineering.redhat.com
Problem is still not fixed. If I will change priority with clone jobs new job have still the same priority as old job.

Comment 2 Raymond Mancy 2011-11-08 12:29:37 UTC
Ok, that is a slightly different problem than what you originally described.

You originally you said you were having problems going from Urgent to High.
To go above 'Normal', you need special privileges. I would assume that if you have the permission to set the job to "Urgent", then you would also be able to set it to "High".
I'm guessing though that perhaps you don't have the right permission to set the priority that high.

Comment 3 Steven Lawrance 2011-11-08 12:54:02 UTC
Is the priority getting bumped up by the scheduler due to only a single machine matching the recipe?

Comment 4 Raymond Mancy 2011-11-08 13:01:16 UTC
It could be. If it's still in the new state though than it should not have any priority bumping done on it.

Comment 5 Kamil Kolakowski 2011-11-08 13:07:37 UTC
Raymond,

Now when I'm submitting job and if it have priority High I get Normal.
When I'm cloning job - I'm putting there priority High I will get Normal.

So it is really changed.

I don't know if it is fixed because the priority are now always (by default) set to Normal.

Comment 6 Raymond Mancy 2011-11-08 23:43:58 UTC
To set priority higher than Normal, you need to be in the admin or queue_admin group. If you try and set it higher than Normal without being in these groups it will automatically go back to Normal. This is expected behaviour.


Note You need to log in before you can comment on or make changes to this bug.