Bug 728218 - [abrt] nicotine+-1.2.16-4.fc13: uglytree.py:209:on_get_iter:TypeError: 'NoneType' object is not iterable
Summary: [abrt] nicotine+-1.2.16-4.fc13: uglytree.py:209:on_get_iter:TypeError: 'NoneT...
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Fedora
Classification: Fedora
Component: nicotine+
Version: 13
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Mohamed El Morabity
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:72e6ee34
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-08-04 12:20 UTC by koen
Modified: 2011-09-26 00:01 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-09-26 00:01:25 UTC


Attachments (Terms of Use)
File: backtrace (850 bytes, text/plain)
2011-08-04 12:20 UTC, koen
no flags Details

Description koen 2011-08-04 12:20:12 UTC
abrt version: 1.1.14
architecture: x86_64
cmdline: /usr/bin/python /usr/bin/nicotine
component: nicotine+
executable: /usr/bin/nicotine
kernel: 2.6.34.9-69.fc13.x86_64
package: nicotine+-1.2.16-4.fc13
reason: uglytree.py:209:on_get_iter:TypeError: 'NoneType' object is not iterable
release: Fedora release 13 (Goddard)
time: 1312460053
uid: 500

backtrace
-----
uglytree.py:209:on_get_iter:TypeError: 'NoneType' object is not iterable

Traceback (most recent call last):
  File "/usr/lib/python2.6/site-packages/pynicotine/gtkgui/userbrowse.py", line 292, in OnFolderClicked
    self.OnDownloadDirectory(widget)
  File "/usr/lib/python2.6/site-packages/pynicotine/gtkgui/userbrowse.py", line 508, in OnDownloadDirectory
    self.DownloadDirectory(self.selected_folder)
  File "/usr/lib/python2.6/site-packages/pynicotine/gtkgui/userbrowse.py", line 597, in DownloadDirectory
    node = self.DirStore.on_get_iter(dir)
  File "/usr/lib/python2.6/site-packages/pynicotine/gtkgui/uglytree.py", line 209, in on_get_iter
    for i in path:
TypeError: 'NoneType' object is not iterable

Local variables in innermost frame:
node: None
path: None
self: <UglyTree object at 0x4c75aa0 (PyGtkGenericTreeModel at 0x4c9be80)>

How to reproduce
-----
1.dunno

2.
3.

Comment 1 koen 2011-08-04 12:20:14 UTC
Created attachment 516694 [details]
File: backtrace

Comment 2 Mohamed El Morabity 2011-09-26 00:01:25 UTC
Fedora 13 is no more supported since 2011/06/24.


Note You need to log in before you can comment on or make changes to this bug.