Bug 728236 - Duplicated Configuration Code out of sync
Summary: Duplicated Configuration Code out of sync
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Dogtag Certificate System
Classification: Retired
Component: Console
Version: 9.0
Hardware: All
OS: All
unspecified
low
Target Milestone: ---
Assignee: Ade Lee
QA Contact: Ben Levenson
URL:
Whiteboard:
Depends On:
Blocks: 730765
TreeView+ depends on / blocked
 
Reported: 2011-08-04 13:31 UTC by Adam Young
Modified: 2017-08-04 14:54 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-08-04 14:54:05 UTC


Attachments (Terms of Use)
PAtch to sync the configuration between the two code bases (1.79 KB, patch)
2011-08-04 13:31 UTC, Adam Young
no flags Details | Diff
Removes the duplicated code and builds by copying from the common component (86.45 KB, patch)
2011-08-04 13:33 UTC, Adam Young
no flags Details | Diff

Description Adam Young 2011-08-04 13:31:48 UTC
Created attachment 516703 [details]
PAtch to sync the configuration between the two code bases

Description of problem:

Becasue the Console and the Server must agree on several configuration isses, such as ports, they share a set of classes in the package: com.netscape.certsrv.common.  However, this code had been copied in the tree, and was getting out of sync:  changes made in one place were  not reflected in another.  Additionally, tools that attempt to build the entire tree as one namespace complained that the class was multiply defined.

Version-Release number of selected component (if applicable):

9.0 and earlier

How reproducible:

100%

Steps to Reproduce:
  import code base into eclipse

  
Actual results:
  Code fails to compile due to duplicated classes.


Expected results:
   Code should compile

Additional info:

Comment 1 Adam Young 2011-08-04 13:33:41 UTC
Created attachment 516704 [details]
Removes the duplicated code and builds by copying from the common component


Note You need to log in before you can comment on or make changes to this bug.