Bug 728237 - RuntimeExeptions thrown when no entitlements can be found for products
Summary: RuntimeExeptions thrown when no entitlements can be found for products
Keywords:
Status: CLOSED DUPLICATE of bug 708058
Alias: None
Product: Candlepin
Classification: Community
Component: candlepin
Version: 0.5
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ---
: ---
Assignee: Bryan Kearney
QA Contact: John Sefler
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-08-04 13:34 UTC by Brenton Leanhardt
Modified: 2015-05-14 15:23 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-08-15 14:22:25 UTC


Attachments (Terms of Use)

Description Brenton Leanhardt 2011-08-04 13:34:43 UTC
Description of problem:

In production we are seeing a number of these exceptions thrown everyday.  There were 546 in July and 48 so far this month.  Either these cases are exceptional and need to be fixed or they shouldn't return 500s.

We're running candlepin-jboss-0.3.14-1.el5.

Caused by: java.lang.RuntimeException: No entitlements for products: [69]
        at org.fedoraproject.candlepin.controller.CandlepinPoolManager.entitleByProducts(CandlepinPoolManager.java:378)
        at org.fedoraproject.candlepin.controller.CandlepinPoolManager$$EnhancerByGuice$$808fbb68.CGLIB$entitleByProducts$4(<generated>)
        at org.fedoraproject.candlepin.controller.CandlepinPoolManager$$EnhancerByGuice$$808fbb68$$FastClassByGuice$$630d9dad.invoke(<generated>)
        at com.google.inject.internal.cglib.proxy.MethodProxy.invokeSuper(MethodProxy.java:228)
        at com.google.inject.InterceptorStackCallback$InterceptedMethodInvocation.proceed(InterceptorStackCallback.java:64)
        at com.wideplay.warp.persist.jpa.JpaLocalTxnInterceptor.invoke(JpaLocalTxnInterceptor.java:68)
        at com.google.inject.InterceptorStackCallback$InterceptedMethodInvocation.proceed(InterceptorStackCallback.java:64)
        at com.google.inject.InterceptorStackCallback.intercept(InterceptorStackCallback.java:44)
        at org.fedoraproject.candlepin.controller.CandlepinPoolManager$$EnhancerByGuice$$808fbb68.entitleByProducts(<generated>)
        at org.fedoraproject.candlepin.resource.ConsumerResource.bindByProducts(ConsumerResource.java:489)
        at org.fedoraproject.candlepin.resource.ConsumerResource.bind(ConsumerResource.java:669)
        at org.fedoraproject.candlepin.resource.ConsumerResource$$EnhancerByGuice$$72edc4ae.CGLIB$bind$2(<generated>)
        at org.fedoraproject.candlepin.resource.ConsumerResource$$EnhancerByGuice$$72edc4ae$$FastClassByGuice$$54c158ab.invoke(<generated>)
....

Comment 1 Brenton Leanhardt 2011-08-15 14:21:39 UTC
Just an update on this:

We've seen this call fail 183 times this month.  Users have successfully made this call 595 times.

This appears to be a duplicate of https://bugzilla.redhat.com/show_bug.cgi?id=708058 filed last May.

Comment 2 Brenton Leanhardt 2011-08-15 14:22:25 UTC

*** This bug has been marked as a duplicate of bug 708058 ***


Note You need to log in before you can comment on or make changes to this bug.