Bug 728253 - The "yum history addon-info" produces invalid output
Summary: The "yum history addon-info" produces invalid output
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: yum
Version: 6.1
Hardware: All
OS: Linux
medium
medium
Target Milestone: rc
: 6.2
Assignee: James Antill
QA Contact: Red Hat Satellite QA List
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-08-04 14:05 UTC by Jaromir Hradilek
Modified: 2014-01-21 06:24 UTC (History)
1 user (show)

Fixed In Version: yum-3.2.29-18.el6
Doc Type: Bug Fix
Doc Text:
Prior to this update, when the "yum -q history addon-info last saved_tx" command was used to store transaction data in a file, an attempt to supply this file to the "yum load-transaction" command in order to repeat the transaction failed with an error, because the output contained extra lines. This update corrects the underlying source code to make sure the "yum -q history addon-info last saved_tx" command produces valid output, and adapts "yum load-transaction" to accept older version of the output as well.
Clone Of:
Environment:
Last Closed: 2011-12-06 17:34:49 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2011:1702 normal SHIPPED_LIVE yum bug fix and enhancement update 2011-12-06 00:49:49 UTC

Description Jaromir Hradilek 2011-08-04 14:05:39 UTC
Description of problem:

When the "yum -q history addon-info last saved_tx" command is used to store transaction data in a file, an attempt to use the resulting file to repeat the transaction fails with an error, because the output contains extra lines.

Version-Release number of selected component (if applicable):
yum-3.2.29-17.el6.noarch

How reproducible:
Always

Steps to Reproduce:
1. Run the following command to save the latest transaction to a file:

   yum -q history addon-info last saved_tx > latest.yumtx

2. Copy the latest.yumtx file to a machine with identical transaction history, and attempt to repeat the saved transaction:

   yum load-transaction latest.yumtx

3. See the error message.
  
Actual results:
Error: rpmdb ver mismatched saved transaction version,  aborting.

Expected results:
The transaction stored in the file is repeated successfully.

Additional info:
None.

Comment 1 James Antill 2011-08-04 14:38:10 UTC
Have two simple fixes that are upstream:

1. Produce just the load-ts data when someone runs "yum -q history addon-info saved_tx".

2. Accept the old output in load-ts.

...both are only a couple of lines of changes.

Comment 6 Jaromir Hradilek 2011-10-26 15:27:45 UTC
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
Prior to this update, when the "yum -q history addon-info last saved_tx" command was used to store transaction data in a file, an attempt to supply this file to the "yum load-transaction" command in order to repeat the transaction failed with an error, because the output contained extra lines. This update corrects the underlying source code to make sure the "yum -q history addon-info last saved_tx" command produces valid output, and adapts "yum load-transaction" to accept older version of the output as well.

Comment 7 errata-xmlrpc 2011-12-06 17:34:49 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2011-1702.html


Note You need to log in before you can comment on or make changes to this bug.