Bug 728280 - TypeError: %d format: a number is required, not NoneType
Summary: TypeError: %d format: a number is required, not NoneType
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: anaconda
Version: 6.2
Hardware: i686
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Ales Kozumplik
QA Contact: Release Test Team
URL:
Whiteboard: abrt_hash:c198dab5a9587db71d3f460e368...
Depends On:
Blocks: 691780
TreeView+ depends on / blocked
 
Reported: 2011-08-04 15:13 UTC by Andrew Jones
Modified: 2014-09-30 23:40 UTC (History)
5 users (show)

Fixed In Version: anaconda-13.21.127-1
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-12-06 10:40:43 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2011:1565 normal SHIPPED_LIVE anaconda bug fix and enhancement update 2011-12-06 00:39:12 UTC

Description Andrew Jones 2011-08-04 15:13:31 UTC
abrt version: 2.0.5
executable:     /mnt/runtime/usr/bin/python
hashmarkername: anaconda
kernel:         2.6.32-174.el6.i686
product:        Red Hat Enterprise Linux
reason:         TypeError: %d format: a number is required, not NoneType
time:           Thu Aug  4 15:11:43 2011
version:        6.2

description:
:The following was filed automatically by anaconda:
:anaconda 13.21.125 exception report
:Traceback (most recent call first):
:  File "/usr/lib/anaconda/storage/devicelibs/edd.py", line 108, in devname_from_pci_dev
:    'dev' : self.edd.ata_device
:  File "/usr/lib/anaconda/storage/devicelibs/edd.py", line 208, in get_edd_dict
:    name = matcher.devname_from_pci_dev()
:  File "/usr/lib/anaconda/storage/__init__.py", line 433, in reset
:    self.eddDict = get_edd_dict(self.partitioned)
:  File "/usr/lib/anaconda/storage/__init__.py", line 103, in storageInitialize
:    storage.reset()
:  File "/usr/lib/anaconda/dispatch.py", line 208, in moveStep
:    rc = stepFunc(self.anaconda)
:  File "/usr/lib/anaconda/dispatch.py", line 126, in gotoNext
:    self.moveStep()
:  File "/usr/lib/anaconda/gui.py", line 1477, in setScreen
:    self.anaconda.dispatch.gotoNext()
:  File "/usr/lib/anaconda/gui.py", line 1390, in nextClicked
:    self.setScreen ()
:TypeError: %d format: a number is required, not NoneType

Comment 2 Andrew Jones 2011-08-04 16:05:14 UTC
Got this crash at disk initialization when attempting to install a latest RHEL
6.2 Xen full-virt guest. There were no problems with a Xen paravirt guest.

Comment 3 Andrew Jones 2011-08-04 16:21:00 UTC
I was also able to "convert" the successfully installed paravirt guest to a full-virt guest using the following steps.

1) destroy the config for the paravirt guest, but not the disk image
2) virt-install using the RHEL 6.1 release for the repo and the old paravirt guest disk image for the disk image
3) select update instead of reinstall and to rewrite the boot loader
4) anaconda immediately says the update is complete (since the image actually has packages that are all >= to 6.1) and prompts for reboot
5) the reboot succeeds and the guest works fine, already running on the -174 kernel

Comment 4 Ales Kozumplik 2011-08-05 12:29:48 UTC
(note that the attachment is missing here because of bug 727243)

Comment 5 Ales Kozumplik 2011-08-05 12:59:11 UTC
Andrew,

Thanks for reporting this, can you please attach all /sys/firmware/edd/int13_dev*/host_bus

or confirm the files do not exist?

Thank you.

Comment 6 Andrew Jones 2011-08-05 16:56:24 UTC
I had already destroyed the failed guest, so I had to try and recreate it. This time it successfully installed and booted from the 6.2 nightly repo I used, which has

anaconda-13.21.126-1.el6.i686

Comment 7 Ales Kozumplik 2011-08-08 06:21:13 UTC
Nevermind, i had a fix ready for that scenario and since I believe it can occur on some machines (unfortunately including xen) I'll go ahead with it.

Comment 8 Ales Kozumplik 2011-08-08 07:14:50 UTC
Posted a patch with a unit test and a fix. The unit test reproduces the traceback from comment 0:

https://www.redhat.com/archives/anaconda-devel-list/2011-August/msg00079.html

David, can you obtain the acks for this bug please?

Comment 9 Pavel Holica 2011-08-09 11:02:43 UTC
Granting QA ack, but we're unable to reproduce this bug, so only sanity testing will be done.

Comment 10 RHEL Product and Program Management 2011-08-10 14:01:18 UTC
This request was evaluated by Red Hat Product Management for inclusion
in a Red Hat Enterprise Linux maintenance release. Product Management has 
requested further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed 
products. This request is not yet committed for inclusion in an Update release.

Comment 11 Ales Kozumplik 2011-08-11 06:34:29 UTC
fixed by 914d798acdca75ccaf238671d228f80eebb17246 (a02c624673fdc3311f64ba270426006b5261c9cb on master)

Comment 13 Alexander Todorov 2011-08-17 16:08:38 UTC
I wasn't able to reproduce. 

With anaconda-13.21.128 I can successfully install Xen FV guest and the patch is present in the code. Setting Verified=SanityOnly.

Comment 14 errata-xmlrpc 2011-12-06 10:40:43 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2011-1565.html


Note You need to log in before you can comment on or make changes to this bug.