Bug 72835 - epic print non-utf8 accented characters as '?'
epic print non-utf8 accented characters as '?'
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: epic (Show other bugs)
8.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-08-28 05:30 EDT by Dams
Modified: 2008-05-01 11:38 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-02-07 15:39:45 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dams 2002-08-28 05:30:11 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.2.5 (X11; Linux i686; U;) Gecko/20020809

Description of problem:


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. epic <nickname> irc.openprojects.net
2. /join #linux-fr (for example)
3. ask people to make some accented characters.
	

Actual Results:  you will see some '?' in place of accented characters

Expected Results:  should see the accented characters

Additional info:

I'm not sure this can be fix.. People on irc dont use utf8/unicode but latin1/9
(for french people). The accented characters i send other users are printed on
their side as an escape sequence (or something like that..).
Is there a way to workaround and print their accent correctly in my epic ? Must
I change some epic settings ?
Comment 1 Jeremy Katz 2002-08-29 00:58:37 EDT
There's not really a lot that can be done.  There is no defined encoding for
IRC, so you just get random garbage (try joining somewhere where Japanese is
spoken for example)
Comment 2 Jeremy Katz 2003-02-07 15:39:45 EST
Marking as wontfix since there's not a lot than can be done within the protocol.
 Workaround by running in a different locale if you're somewhere where character
sets other than utf-8 are used on irc.

Note You need to log in before you can comment on or make changes to this bug.