Bug 72836 - gnome-panel-screenshot potentially deadly
gnome-panel-screenshot potentially deadly
Status: CLOSED DUPLICATE of bug 71432
Product: Red Hat Public Beta
Classification: Retired
Component: gnome-panel (Show other bugs)
null
All Linux
high Severity medium
: ---
: ---
Assigned To: Havoc Pennington
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-08-28 05:34 EDT by Warren Togami
Modified: 2008-05-01 11:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-08-28 05:34:30 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Warren Togami 2002-08-28 05:34:22 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20020809

Description of problem:
In Gnome2 of Null, if you press the Print-Screen button, gnome-panel-screenshot
runs, taking a screenshot and opening another window.  This is nice, but
potentially deadly in the freak chance that somebody holds down the Print-Screen
button.  The machine will quickly spawn an unlimited number of windows, OOM and die.

This is a disaster waiting to happen... especially for LTSP servers.  One
student holds down Print-Screen, and bam, the entire server and all thin clients
die.

Version-Release number of selected component (if applicable):
Null

How reproducible:
Always

Steps to Reproduce:
1. Login to Gnome2
2. Hold down Print-Screen button.
	

Actual Results:  
OOM.  Crash.  Burn.


Expected Results:  
gnome-panel rate limiting, or perhaps a small finite limit of
gnome-panel-screenshot windows on the screen.
Comment 1 Havoc Pennington 2002-08-28 10:20:56 EDT

*** This bug has been marked as a duplicate of 71432 ***

Note You need to log in before you can comment on or make changes to this bug.