Bug 728408 - Package jbpm-flow and jbpm-flow-builder jars with BRMS 5.2
Summary: Package jbpm-flow and jbpm-flow-builder jars with BRMS 5.2
Keywords:
Status: CLOSED DUPLICATE of bug 727562
Alias: None
Product: JBoss Enterprise BRMS Platform 5
Classification: JBoss
Component: BRE (Expert, Fusion)
Version: BRMS 5.2.0.GA
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ---
: ---
Assignee: Tihomir Surdilovic
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-08-05 02:39 UTC by Ryan Zhang
Modified: 2011-09-15 05:35 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-08-05 02:47:23 UTC
Type: ---


Attachments (Terms of Use)

Description Ryan Zhang 2011-08-05 02:39:22 UTC
Description of problem:

RuleFlow feature have move to separate component since drools 5.2. But they are required for BRMS 5.2.

Part of the clarification of email discussion

I synched up with Mark yesterday.  It is true that it is valuable to encourage users to use bpmn2 as a standard way to create rule flow.  However it is important to keep our release schedule intact.  As we are working towards 5.3 plans closely following we can attempt to support bpmn2 based rules flow in that release.  

So, in conclusion, we will only support .rf format of rule flow in 5.2 and package required jars in the build.  

Package jbpm-flow and jbpm-flow-builder jars with BRMS 5.2.

....
Adding jbpm-bpmn2 would only add the possibility to define RuleFlow using .bpmn2, other than that the behaviour is identical. Even in the Eclipse plugin.  But since bpmn2 is the standardized format, my vote would be to include it.

Not including it means users will need to keep using. rf for supported RuleFlow and would be identical to previous brms version.

Comment 1 Ryan Zhang 2011-08-05 02:47:23 UTC

*** This bug has been marked as a duplicate of bug 727562 ***


Note You need to log in before you can comment on or make changes to this bug.