Bug 728413 - sftp always exits with glibc detected *** sftp: free(): invalid pointer:
Summary: sftp always exits with glibc detected *** sftp: free(): invalid pointer:
Keywords:
Status: CLOSED DUPLICATE of bug 732989
Alias: None
Product: Fedora
Classification: Fedora
Component: openssh
Version: 15
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Jan F. Chadima
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-08-05 03:39 UTC by Hin-Tak Leung
Modified: 2011-08-25 08:35 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-08-25 08:35:49 UTC


Attachments (Terms of Use)

Description Hin-Tak Leung 2011-08-05 03:39:12 UTC
Description of problem:

Since upgrading to fedora 15, running sftp always seem to exit with 4 lines of:

sftp> exit
*** glibc detected *** sftp: free(): invalid pointer: 0x9d9d9d9d9d9d9d9d ***
*** glibc detected *** sftp: free(): invalid pointer: 0x9d9d9d9d9d9d9d9d ***
*** glibc detected *** sftp: free(): invalid pointer: 0x9d9d9d9d9d9d9d9d ***
*** glibc detected *** sftp: free(): invalid pointer: 0x9d9d9d9d9d9d9d9d ***

sftp otherwise seems to be working correctly, so this is just annoying but causes no harm as far as I know.

Version-Release number of selected component (if applicable):
openssh-clients-5.6p1-33.fc15.1.x86_64


How reproducible:
Always


Steps to Reproduce:
1. (as root, if it isn't currently running) /etc/rc.d/init.d/sshd start
2. as user, do "sftp localhost"
3. Just type "exit" to get out of sftp.
  
Actual results:

4 lines of:

*** glibc detected *** sftp: free(): invalid pointer: 0x9d9d9d9d9d9d9d9d ***
*** glibc detected *** sftp: free(): invalid pointer: 0x9d9d9d9d9d9d9d9d ***
*** glibc detected *** sftp: free(): invalid pointer: 0x9d9d9d9d9d9d9d9d ***
*** glibc detected *** sftp: free(): invalid pointer: 0x9d9d9d9d9d9d9d9d ***

Expected results:
It should produces no such warnings.

Additional info:
If this is meant to be a glibc/gcc feature, please feel free to re-file to the other components.

Comment 1 Jan F. Chadima 2011-08-09 09:13:00 UTC
I can not reproduce it. Have you any extra conditions (locale, commands inside sftp etc.) which causes this end?

Comment 2 Hin-Tak Leung 2011-08-09 15:06:01 UTC
I have these sent automatically by gnome (i.e. I don't know where they were set).

declare -x SSH_ASKPASS="/usr/libexec/openssh/gnome-ssh-askpass"
declare -x SSH_AUTH_SOCK="/tmp/keyring-xKkKxI/ssh"


I have LANG=en_GB.utf8 . AFAIK the only relevant customization I do is alias ssh='ssh -C -X ' in my bashrc . Tried unsetting that on the command line and the problem persists.

There is no simplier sftp session - just start sshd, sftp localhost (which does it without password - seems ssh-askpass does it auto), then just type exit.

Comment 3 Jan F. Chadima 2011-08-15 06:37:53 UTC
please try update all and then if bug persists report the version of your glibc.

Comment 4 Hin-Tak Leung 2011-08-15 08:57:59 UTC
(In reply to comment #3)
> please try update all and then if bug persists report the version of your
> glibc.

Hmm, I run "yum upgrade" every couple of days so am quite up to date. According to "rpm -qa --last", I picked up glibc-2.14-5 on Wed 10 Aug, and  
 openssh-clients-5.6p1-34.fc15.1 on Sat 06 Aug. The problem is still here. Just tried it (using two gnome windows):

    /etc/rc.d/init.d/sshd start (as root)

    sftp localhost (as user)
    > exit

Comment 5 Tomas Mraz 2011-08-15 10:18:31 UTC
What do you have in the /etc/nsswitch.conf configuration file?

Comment 6 Hin-Tak Leung 2011-08-15 10:31:14 UTC
(In reply to comment #5)
> What do you have in the /etc/nsswitch.conf configuration file?

I have not done anything to it myself, so I am not sure why it has a more recent time stamp than the package build date of "rpm -qi glibc" - it must be updated by something else or a pre-install-script in the rpm? Anyway, here it is.

# rpm -V glibc
# ls -l  /etc/nsswitch.conf
-rw-r--r--. 1 root root 1720 Aug  9 17:06 /etc/nsswitch.conf
# grep -v '^#'  /etc/nsswitch.conf


passwd:     files
shadow:     files
group:      files

hosts:      files mdns4_minimal [NOTFOUND=return] dns


bootparams: nisplus [NOTFOUND=return] files

ethers:     files
netmasks:   files
networks:   files
protocols:  files
rpc:        files
services:   files

netgroup:   nisplus

publickey:  nisplus

automount:  files nisplus
aliases:    files nisplus
-----------------------------

Comment 7 Tomas Mraz 2011-08-15 10:59:11 UTC
Can you please try to temporarily remove the 'mdns4_minimal [NOTFOUND=return]' part from the hosts line and try the sftp again?

Comment 8 Hin-Tak Leung 2011-08-15 12:30:57 UTC
(In reply to comment #7)
> Can you please try to temporarily remove the 'mdns4_minimal [NOTFOUND=return]'
> part from the hosts line and try the sftp again?

No improvement. Do I need to restart anything (or log fully out of my gnome session) for this change to take effect?

Comment 9 Tomas Mraz 2011-08-15 13:07:57 UTC
No, this should take effect immediately. Then the mdns4 resolver is not the culprit.

Comment 10 Jan F. Chadima 2011-08-25 08:35:49 UTC

*** This bug has been marked as a duplicate of bug 732989 ***


Note You need to log in before you can comment on or make changes to this bug.