Bug 728439 - unable to reboot in rescue mode
Summary: unable to reboot in rescue mode
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: systemd
Version: 16
Hardware: All
OS: Linux
unspecified
unspecified
Target Milestone: ---
Assignee: systemd-maint
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 733598 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-08-05 07:46 UTC by He Rui
Modified: 2011-11-11 01:25 UTC (History)
9 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-11-11 01:25:55 UTC


Attachments (Terms of Use)
hanged screen.png (3.15 KB, image/png)
2011-08-05 07:46 UTC, He Rui
no flags Details
dmesg.txt (37.57 KB, text/plain)
2011-08-05 07:47 UTC, He Rui
no flags Details
strace reboot output (12.96 KB, text/plain)
2011-08-05 07:48 UTC, He Rui
no flags Details

Description He Rui 2011-08-05 07:46:27 UTC
Created attachment 516838 [details]
hanged screen.png

Description of problem:
Ran F16 alpha tc1 in rescue mode, when prompted, clicked reboot, it hanged there. 

Version-Release number of selected component (if applicable):
anaconda 16.14

How reproducible:
100%

Steps to Reproduce:
1. Run rescue mode in F16-alpha tc1 
2. when prompted, click reboot

Comment 1 He Rui 2011-08-05 07:47:23 UTC
Created attachment 516839 [details]
dmesg.txt

Comment 2 He Rui 2011-08-05 07:48:02 UTC
Created attachment 516841 [details]
strace reboot output

Comment 3 Andre Robatino 2011-08-12 03:33:25 UTC
I've seen this as well, both i386 and x86_64, up to and including RC3.

Comment 4 Andre Robatino 2011-08-15 00:46:19 UTC
I can go to VT #2 and execute commands. But reboot, poweroff, etc. do nothing (I just get the prompt back). This happens even if I go to a VT immediately after seeing the first text prompt ("Choose a Language").

Comment 5 Andre Robatino 2011-08-15 23:02:51 UTC
Problem still exists in RC4. The same thing happens if you try to use "q" to quit debug mode - it appears to hang, and you can go to a VT, but reboot just returns the prompt.

Comment 6 Andre Robatino 2011-08-26 08:08:38 UTC
Still exists in Alpha Gold (AKA RC5).

Comment 7 Brian Lane 2011-08-29 17:10:16 UTC
*** Bug 733598 has been marked as a duplicate of this bug. ***

Comment 8 Andre Robatino 2011-08-31 19:59:55 UTC
Appears fixed in 16 Beta TC1 with respect to rebooting from rescue mode. In debug mode, 'q' still hangs, but now you can go to a VT and the reboot command works there.

Comment 9 Andre Robatino 2011-09-09 05:48:28 UTC
Behavior is same in TC2 as in TC1.

Comment 10 Fedora Admin XMLRPC Client 2011-10-20 16:30:36 UTC
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.

Comment 11 Michal Schmidt 2011-11-11 01:25:55 UTC
Reboot from anaconda rescue mode works in F16 GA.


Note You need to log in before you can comment on or make changes to this bug.