Bug 728471 - yum-plugin-local tracebacks on permission denied failures
yum-plugin-local tracebacks on permission denied failures
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: yum-utils (Show other bugs)
16
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Seth Vidal
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-08-05 05:28 EDT by Frank Murphy
Modified: 2014-01-21 18:18 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-08-11 15:00:06 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Frank Murphy 2011-08-05 05:28:37 EDT
Description of problem: Permission Denied, uncertain of what to blame.


Version-Release number of selected component (if applicable):
rpm -qa yum\*
yum-utils-1.1.30-3.fc15.noarch
yum-langpacks-0.2.2-1.fc16.noarch
yum-updateonboot-1.1.30-3.fc15.noarch
yum-plugin-fastestmirror-1.1.30-3.fc15.noarch
yum-presto-0.7.0-1.fc16.noarch
yumex-3.0.3-1.fc16.noarch
yum-plugin-remove-with-leaves-1.1.30-3.fc15.noarch
yum-plugin-local-1.1.30-3.fc15.noarch
yum-plugin-protectbase-1.1.30-3.fc15.noarch
yum-metadata-parser-1.1.4-5.fc16.i686
yum-3.4.3-4.fc16.noarch
yum-plugin-versionlock-1.1.30-3.fc15.noarch



How reproducible: Always


Steps to Reproduce:
1. yum update to local repo
2.
3.
  
Actual results:
yum install xorg-x11-xinit-session
Loaded plugins: fastestmirror, langpacks, local, presto, protectbase, remove-with-leaves, versionlock
Loading mirror speeds from cached hostfile
 * fedora: mirrors.ircam.fr
 * updates-testing: ftp.esat.net
0 packages excluded due to repository protections
Setting up Install Process
Resolving Dependencies
--> Running transaction check
---> Package xorg-x11-xinit-session.i686 0:1.3.1-1.fc16 will be installed
--> Finished Dependency Resolution

Dependencies Resolved

==============================================================================================================================================
 Package                                     Arch                      Version                              Repository                   Size
==============================================================================================================================================
Installing:
 xorg-x11-xinit-session                      i686                      1.3.1-1.fc16                         fedora                       12 k

Transaction Summary
==============================================================================================================================================
Install       1 Package

Total download size: 12 k
Installed size: 12 k
Is this ok [y/N]: y
Downloading Packages:
xorg-x11-xinit-session-1.3.1-1.fc16.i686.rpm                                                                           |  12 kB     00:00     
Traceback (most recent call last):
  File "/usr/bin/yum", line 29, in <module>
    yummain.user_main(sys.argv[1:], exit_code=True)
  File "/usr/share/yum-cli/yummain.py", line 309, in user_main
    errcode = main(args)
  File "/usr/share/yum-cli/yummain.py", line 223, in main
    return_code = base.doTransaction()
  File "/usr/share/yum-cli/cli.py", line 526, in doTransaction
    problems = self.downloadPkgs(downloadpkgs, callback_total=self.download_callback_total_cb) 
  File "/usr/lib/python2.7/site-packages/yum/__init__.py", line 2048, in downloadPkgs
    self.plugins.run('postdownload', pkglist=pkglist, errors=errors)
  File "/usr/lib/python2.7/site-packages/yum/plugins.py", line 184, in run
    func(conduitcls(self, self.base, conf, **kwargs))
  File "/usr/lib/yum-plugins/local.py", line 69, in postdownload_hook
    os.makedirs(local_repo_dir)
  File "/usr/lib/python2.7/os.py", line 157, in makedirs
    mkdir(name, mode)
OSError: [Errno 13] Permission denied: '/mystore/localrepo'



Expected results: no errors


Additional info:
drwxr-xr-x.   2 root root     0 Aug  5 10:13 mystore
localrepo mounted with autofs
Comment 1 James Antill 2011-08-08 10:48:58 EDT
It's yum-plugin-local ... which is trying to copy the downloaded files to the dir. specified, but can't. My guess is root squash is the reason why it can't.
Comment 2 Frank Murphy 2011-08-11 07:03:05 EDT
root squash?
Comment 3 Frank Murphy 2011-08-11 15:00:06 EDT
Found the cause, new ISP supplied modem, had changed private ip range on internal router, the nfs server with it's static ip was then outside the range.

Apologies for any noise

Note You need to log in before you can comment on or make changes to this bug.