Bug 728497 - [virt-manager]Error dialog shown up when add storage to guest
Summary: [virt-manager]Error dialog shown up when add storage to guest
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: virt-manager
Version: 6.2
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: rc
: ---
Assignee: Cole Robinson
QA Contact: Virtualization Bugs
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-08-05 11:03 UTC by zhe peng
Modified: 2016-04-26 13:43 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
No description necessary
Clone Of:
Environment:
Last Closed: 2011-12-06 16:15:09 UTC


Attachments (Terms of Use)
full debug info (11.67 KB, text/plain)
2011-08-30 05:56 UTC, zhe peng
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2011:1642 normal SHIPPED_LIVE virt-manager bug fix and enhancement update 2011-12-06 00:50:37 UTC

Description zhe peng 2011-08-05 11:03:45 UTC
Description of problem:
when add storage into a guest, an error dialog will shown up,error msg is:'NoneType' object has no attribute 'rfind',only occur when using CDROM/ISO to install guest.


Version-Release number of selected component (if applicable):
virt-manager-0.9.0-5.el6
python-virtinst-0.600.0-2.el6
libvirt-0.9.4-1.el6


How reproducible:
always

Steps to Reproduce:
1.lunch virt-manager,install a guest using CDROM or ISO
2.during guest installing,click Force Off to shutdown the guest
3.in guest detail view ,click "add hardware" button to add a new storage
4.make all to default,click "finish"
  
Actual results:
error dialog shown up, 
 Storage parameter error
'NoneType' object has no attribute 'rfind'

in debug info:
[Fri, 05 Aug 2011 06:56:03 virt-manager 12313] DEBUG (error:109) Validation Error: Storage parameter error.
[Fri, 05 Aug 2011 06:57:01 virt-manager 12313] DEBUG (error:109) Validation Error: Storage parameter error.



Expected results:
 storage can be added successful.

Additional info:
 this issue only occured when use CDROM/ISO install guest, not happend if use http install. 
 can't reproduce with virt-manager-0.8.6-4.el6,so seems a regression bug.

Comment 2 Cole Robinson 2011-08-29 16:59:48 UTC
I can't seem to reproduce. Can you provide the full output of virt-manager --debug from guest creation to reproducing the error? Thanks

Comment 3 zhe peng 2011-08-30 05:56:11 UTC
Created attachment 520526 [details]
full debug info

Comment 4 Cole Robinson 2011-08-30 18:49:51 UTC
Thanks a bunch, that helped. Issue is fixed upstream now:

http://git.fedorahosted.org/git?p=virt-manager.git;a=commit;h=9a46aa41e092e73ed1596c361acbca65ac3cbe95

Comment 5 Cole Robinson 2011-08-30 19:39:06 UTC
Fixed in virt-manager-0.9.0-6.el6

Comment 7 zhe peng 2011-09-01 07:12:49 UTC
Verify with:
libvirt-0.9.4-6.el6
qemu-kvm-0.12.1.2-2.184.el6
kernel-2.6.32-191.el6
virt-manager-0.9.0-6.el6
python-virtinst-0.600.0-3.el6

1.lunch virt-manager,install a guest using CDROM or ISO
2.during guest installing,click Force Off to shutdown the guest
3.in guest detail view ,click "add hardware" button to add a new storage
4.make all to default,click "finish"

now storage can be added successful. no error in debug info
verification passed.

Comment 8 Cole Robinson 2011-11-07 16:41:44 UTC
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
No description necessary

Comment 9 errata-xmlrpc 2011-12-06 16:15:09 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2011-1642.html


Note You need to log in before you can comment on or make changes to this bug.