Bug 72850 - passwords are created as {crypt}..., not {CRYPT}...
passwords are created as {crypt}..., not {CRYPT}...
Status: CLOSED CANTFIX
Product: Red Hat Linux
Classification: Retired
Component: gq (Show other bugs)
8.0
i386 Linux
medium Severity low
: ---
: ---
Assigned To: Nalin Dahyabhai
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-08-28 08:16 EDT by Simon Matter
Modified: 2008-05-01 11:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-10-18 13:34:38 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Simon Matter 2002-08-28 08:16:46 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.77 [de] (X11; U; Linux 2.2.19-6.2.16 i686)

Description of problem:
When changing a password with gq, it is created as {crypt}.... while any other
tool known to me uses capital letter like this {CRYPT}...

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. enter/modify a userPassword attribute with gq
2.
3.
	

Actual Results:  The password looks something like {crypt}deQUTgVQoNeDM

Expected Results:  The password looks something like {CRYPT}deQUTgVQoNeDM

Additional info:

I know that this is not a bug but it was better if gq uses capital letters. All
the ldap tool I know use capital letters. Tools like ldapdiff generate lots of
changes if {CRYPT} changes its case. The patch below 'fixes' the 'bug':

[root@dhcp-141-104 SOURCES]# cat gq-0.6.0-cryptcase.patch
--- src/dt_password.c.orig      Tue Jun 18 21:56:19 2002
+++ src/dt_password.c   Wed Aug 28 13:59:29 2002
@@ -120,7 +120,7 @@
      if(salt->str[1] == '+') salt->str[1] = '.';
      salt->str[2] = 0;
 
-     strcpy(gb->data, "{crypt}");
+     strcpy(gb->data, "{CRYPT}");
      des_fcrypt(password, salt->str, gb->data + strlen(gb->data));
      g_byte_array_set_size(gb, strlen(gb->data));
Comment 1 Bill Nottingham 2006-08-07 16:10:43 EDT
Red Hat Linux is no longer supported by Red Hat, Inc. If you are still
running Red Hat Linux, you are strongly advised to upgrade to a
current Fedora Core release or Red Hat Enterprise Linux or comparable.
Some information on which option may be right for you is available at
http://www.redhat.com/rhel/migrate/redhatlinux/.

Red Hat apologizes that these issues have not been resolved yet. We do
want to make sure that no important bugs slip through the cracks.
Please check if this issue is still present in a current Fedora Core
release. If so, please change the product and version to match, and
check the box indicating that the requested information has been
provided. Note that any bug still open against Red Hat Linux on will be
closed as 'CANTFIX' on September 30, 2006. Thanks again for your help.
Comment 2 Bill Nottingham 2006-10-18 13:34:38 EDT
Red Hat Linux is no longer supported by Red Hat, Inc. If you are still
running Red Hat Linux, you are strongly advised to upgrade to a
current Fedora Core release or Red Hat Enterprise Linux or comparable.
Some information on which option may be right for you is available at
http://www.redhat.com/rhel/migrate/redhatlinux/.

Closing as CANTFIX.

Note You need to log in before you can comment on or make changes to this bug.