Bug 728548 - nfsiostat: No NFS mount points were found
nfsiostat: No NFS mount points were found
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: nfs-utils (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Steve Dickson
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-08-05 10:14 EDT by Jeff Layton
Modified: 2011-10-04 13:10 EDT (History)
4 users (show)

See Also:
Fixed In Version: nfs-utils-1.2.5-1.fc17
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-10-04 13:10:11 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Jeff Layton 2011-08-05 10:14:52 EDT
I have a nfs mount:

salusa:/git/ mounted on /net/salusa/git with fstype nfs4 statvers=1.0
	opts:	rw,vers=4,rsize=1048576,wsize=1048576,namlen=255,acregmin=3,acregmax=60,acdirmin=30,acdirmax=60,hard,proto=tcp6,port=0,timeo=600,retrans=2,sec=sys,clientaddr=2001:470:8:d63:2e0:4dff:febf:6ba,minorversion=0,local_lock=none
	age:	4705

...(etc)...but when I run nfsiostat, it fails to find it:

$ nfsiostat
No NFS mount points were found

This problem also exists in f15, so it's probably been an issue for a little while.
Comment 1 Jeff Layton 2011-08-05 10:15:15 EDT
$ rpm -q nfs-utils
nfs-utils-1.2.4-0.fc15.x86_64
Comment 2 Chuck Lever 2011-08-05 17:14:40 EDT
I can replicate your results with an older version called iostat-ms.

[cel@seurat bin]$ iostat-ms
No NFS mount points were found

[cel@seurat bin]$ mount
rootfs on / type rootfs (rw)
/proc on /proc type proc (rw,relatime)
/sys on /sys type sysfs (rw,relatime)
udev on /dev type devtmpfs (rw,relatime,size=502996k,nr_inodes=125749,mode=755)
devpts on /dev/pts type devpts (rw,relatime,gid=5,mode=620,ptmxmode=000)
tmpfs on /dev/shm type tmpfs (rw,relatime)
/dev/sda3 on / type xfs (rw,relatime,attr2,noquota)
/proc/bus/usb on /proc/bus/usb type usbfs (rw,relatime)
/dev/sda1 on /boot type ext4 (rw,relatime,barrier=1,data=ordered)
tmpfs on /tmp type tmpfs (rw,relatime)
none on /proc/sys/fs/binfmt_misc type binfmt_misc (rw,relatime)
sunrpc on /var/lib/nfs/rpc_pipefs type rpc_pipefs (rw,relatime)
/etc/auto.misc on /misc type autofs (rw,relatime,fd=7,pgrp=1733,timeout=300,minproto=5,maxproto=5,indirect)
-hosts on /net type autofs (rw,relatime,fd=13,pgrp=1733,timeout=300,minproto=5,maxproto=5,indirect)
gvfs-fuse-daemon on /home/cel/.gvfs type fuse.gvfs-fuse-daemon (rw,nosuid,nodev,relatime,user_id=1046,group_id=100)
-hosts on /net/klimt.1015granger.net/.domainroot-1015granger.net type autofs (rw,relatime,fd=13,pgrp=1733,timeout=300,minproto=5,maxproto=5,offset)
-hosts on /net/klimt.1015granger.net/share type autofs (rw,relatime,fd=13,pgrp=1733,timeout=300,minproto=5,maxproto=5,offset)
klimt.1015granger.net:/share/ on /net/klimt.1015granger.net/share type nfs4 (rw,nosuid,nodev,relatime,vers=4,rsize=1048576,wsize=1048576,namlen=255,hard,proto=tcp,port=0,timeo=600,retrans=2,sec=sys,clientaddr=192.168.1.59,minorversion=0,addr=192.168.1.55)
klimt.1015granger.net:/share/home on /net/klimt.1015granger.net/share/home type nfs4 (rw,nosuid,nodev,relatime,vers=4,rsize=1048576,wsize=1048576,namlen=255,hard,proto=tcp,port=0,timeo=600,retrans=2,sec=sys,clientaddr=192.168.1.59,minorversion=0,addr=192.168.1.55)
klimt.1015granger.net:/share/multi on /net/klimt.1015granger.net/share/multi type nfs4 (rw,nosuid,nodev,relatime,vers=4,rsize=1048576,wsize=1048576,namlen=255,hard,proto=tcp,port=0,timeo=600,retrans=2,sec=sys,clientaddr=192.168.1.59,minorversion=0,addr=192.168.1.55)
klimt.1015granger.net:/share/single on /net/klimt.1015granger.net/share/single type nfs4 (rw,nosuid,nodev,relatime,vers=4,rsize=1048576,wsize=1048576,namlen=255,hard,proto=tcp,port=0,timeo=600,retrans=2,sec=sys,clientaddr=192.168.1.59,minorversion=0,addr=192.168.1.55)
klimt.1015granger.net:/share/test on /net/klimt.1015granger.net/share/test type nfs4 (rw,nosuid,nodev,relatime,vers=4,rsize=1048576,wsize=1048576,namlen=255,hard,proto=tcp,port=0,timeo=600,retrans=2,sec=sys,clientaddr=192.168.1.59,minorversion=0,addr=192.168.1.55)

[cel@seurat bin]$ iostat-ms /net/klimt.1015granger.net
Traceback (most recent call last):
  File "/home/cel/bin/iostat-ms", line 537, in <module>
    iostat_command(prog)
  File "/home/cel/bin/iostat-ms", line 475, in iostat_command
    interval = int(arg)
ValueError: invalid literal for int() with base 10: '/net/klimt.1015granger.net'

[cel@seurat bin]$ iostat-ms /net/klimt.1015granger.net/share
No NFS mount points were found

[cel@seurat bin]$ iostat-ms klimt.1015granger.net:/share
Traceback (most recent call last):
  File "/home/cel/bin/iostat-ms", line 537, in <module>
    iostat_command(prog)
  File "/home/cel/bin/iostat-ms", line 475, in iostat_command
    interval = int(arg)
ValueError: invalid literal for int() with base 10: 'klimt.1015granger.net:/share'

[cel@seurat bin]$
Comment 3 Chuck Lever 2011-08-08 16:09:07 EDT
I cannot reproduce your results with the most recent version of nfs-iostat.py on Fedora 14; it works as expected when no argument is specified.  Maybe we don't have the a full reproducer yet.

Note You need to log in before you can comment on or make changes to this bug.