Bug 728577 - SELinux is preventing /bin/bash "read" access on /bin/bash.
Summary: SELinux is preventing /bin/bash "read" access on /bin/bash.
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Fedora
Classification: Fedora
Component: selinux-policy
Version: 12
Hardware: i386
OS: Linux
unspecified
medium
Target Milestone: ---
Assignee: Miroslav Grepl
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: setroubleshoot_trace_hash:432dc2e4fca...
: 728578 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-08-05 16:36 UTC by Carlos Lamar
Modified: 2011-08-05 17:31 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-08-05 17:31:03 UTC


Attachments (Terms of Use)

Description Carlos Lamar 2011-08-05 16:36:03 UTC
Summary:

SELinux is preventing /bin/bash "read" access on /bin/bash.

Detailed Description:

[SELinux is in permissive mode. This access was not denied.]

SELinux denied access requested by mysqld_safe. It is not expected that this
access is required by mysqld_safe and this access may signal an intrusion
attempt. It is also possible that the specific version or configuration of the
application is causing it to require additional access.

Allowing Access:

You can generate a local policy module to allow this access - see FAQ
(http://docs.fedoraproject.org/selinux-faq-fc5/#id2961385) Please file a bug
report.

Additional Information:

Source Context                system_u:system_r:mysqld_safe_t:s0
Target Context                system_u:object_r:shell_exec_t:s0
Target Objects                /bin/bash [ file ]
Source                        mysqld_safe
Source Path                   /bin/bash
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           bash-4.2.10-5.fc17
Target RPM Packages           bash-4.2.10-5.fc17
Policy RPM                    selinux-policy-3.6.32-127.fc12
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Permissive
Plugin Name                   catchall
Host Name                     (removed)
Platform                      Linux (removed) 2.6.32.26-175.fc12.i686.PAE #1
                              SMP Wed Dec 1 21:45:50 UTC 2010 i686 i686
Alert Count                   3
First Seen                    Fri 05 Aug 2011 08:42:21 AM EDT
Last Seen                     Fri 05 Aug 2011 11:16:19 AM EDT
Local ID                      6dda6e82-8c2e-4088-a0f8-dad53b2b1539
Line Numbers                  

Raw Audit Messages            

node=(removed) type=AVC msg=audit(1312557379.72:7): avc:  denied  { read } for  pid=1599 comm="mysqld_safe" path="/bin/bash" dev=dm-0 ino=133033 scontext=system_u:system_r:mysqld_safe_t:s0 tcontext=system_u:object_r:shell_exec_t:s0 tclass=file

node=(removed) type=SYSCALL msg=audit(1312557379.72:7): arch=40000003 syscall=125 success=yes exit=0 a0=811c000 a1=1000 a2=1 a3=8cd8e0 items=0 ppid=1572 pid=1599 auid=4294967295 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 tty=(none) ses=4294967295 comm="mysqld_safe" exe="/bin/bash" subj=system_u:system_r:mysqld_safe_t:s0 key=(null)



Hash String generated from  catchall,mysqld_safe,mysqld_safe_t,shell_exec_t,file,read
audit2allow suggests:

#============= mysqld_safe_t ==============
allow mysqld_safe_t shell_exec_t:file read;

Comment 1 Daniel Walsh 2011-08-05 17:31:03 UTC
f12 is not supported,  Upgrade to F14 or later releases.

Comment 2 Daniel Walsh 2011-08-05 17:31:23 UTC
*** Bug 728578 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.