Bug 728621 - mod-cluster configuration properties are not fully propagating
mod-cluster configuration properties are not fully propagating
Status: CLOSED CURRENTRELEASE
Product: RHQ Project
Classification: Other
Component: Plugins (Show other bugs)
4.1
All All
medium Severity medium (vote)
: ---
: ---
Assigned To: Stefan Negrea
Mike Foley
:
Depends On:
Blocks: 682349
  Show dependency treegraph
 
Reported: 2011-08-05 16:40 EDT by Mike Foley
Modified: 2012-02-07 14:22 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-02-07 14:22:52 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mike Foley 2011-08-05 16:40:50 EDT
Description of problem:  mod-cluster configuration properties are not fully propagating.  the change is correctly propagating to the MBean, but not further.


Version-Release number of selected component (if applicable):


How reproducible:
100%

Steps to Reproduce:
1.   discover and import JBoss42 with mod-cluster
2.   change a configuration property, such as Flushpackets
3.   observe the property change propagates to the MBean, but not to the mod-cluster manager web page
  
Actual results:

Property change partially propogates to the MBean:  http://localhost/jmx-console/HtmlAdaptor?action=inspectMBean&name=Catalina%3Atype%3DModClusterListener

but ... 

not fully because the change is not showing on this page:  http://localhost:6666/mod_cluster_manage

Expected results:

Property change propogates to this page:  http://localhost:6666/mod_cluster_manage

Additional info:
Comment 1 Stefan Negrea 2011-08-28 12:03:04 EDT
The bug has been fixed. Updating just the JMX properties does not send the properties to the http server as expected. Also, those settings are not persisted so any changes are lost after a server restart. Implemented a three step process to update, propagate, and persist configuration updates.


The correct procedure to update mod_cluster properties for JBoss 42 is:
1) update JMX properties - nothing gets persisted in this step
2) invoke refresh command to propagate updates to httpd
3) persist changes server configuration file so that they are reloaded after a restart
Comment 4 Mike Foley 2011-08-30 10:57:09 EDT
documenting the verification ... changes to property propogating to the mod-cluster admin page

Enable Contexts Disable Contexts
Balancer: mycluster,LBGroup: ,Flushpackets: On,Flushwait: 10000,Ping: 10000000,Smax: 26,Ttl: 60000000,Status: OK,Elected: 103,Read: 1406,Transferred: 0,Connected: 0,Load: 100
Comment 5 Mike Foley 2012-02-07 14:22:52 EST
changing status of VERIFIED BZs for JON 2.4.2 and JON 3.0 to CLOSED/CURRENTRELEASE

Note You need to log in before you can comment on or make changes to this bug.