Bug 728652 - middle button not usable for paste operation, 045e:0084
Summary: middle button not usable for paste operation, 045e:0084
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-mouse
Version: 15
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Peter Hutterer
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-08-06 02:58 UTC by Carl Byington
Modified: 2018-04-11 12:23 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-05-20 21:45:19 UTC


Attachments (Terms of Use)
evtest output (472 bytes, text/plain)
2011-08-06 18:18 UTC, Carl Byington
no flags Details
/var/log/messages (82.76 KB, text/plain)
2011-08-06 18:18 UTC, Carl Byington
no flags Details
xorg.conf.d/00-system-setup-keyboard.conf (321 bytes, text/plain)
2011-08-06 18:19 UTC, Carl Byington
no flags Details
xorg.conf.d/99-mouse-midbuttonemulation.conf (126 bytes, application/octet-stream)
2011-08-06 18:20 UTC, Carl Byington
no flags Details
Xorg.0.log (32.48 KB, text/plain)
2011-08-06 18:20 UTC, Carl Byington
no flags Details
xorg.conf.d/99-mouse-midbuttonemulation.conf (126 bytes, text/plain)
2011-08-06 18:22 UTC, Carl Byington
no flags Details

Description Carl Byington 2011-08-06 02:58:27 UTC
Description of problem:
I have a dell 1555 laptop with attached:
Bus 007 Device 002: ID 045e:0084 Microsoft Corp. Basic Optical Mouse

The middle button is used for both scrolling, and as a button. On F15, it scrolls, but middle button press does nothing.

xev shows:
left button = 1
right button = 3
scroll up = 4
scroll down = 5

pressing the middle (scroll) button does not cause any input that xev sees.

The middle button worked on F14 on a different laptop.

xmodmap -pp shows physical buttons 1..12 mapped to button codes 1..12



Version-Release number of selected component (if applicable):
xorg-x11-drv-mouse-1.6.99.901-2.fc15.x86_64

How reproducible:
always

Steps to Reproduce:
1. open terminal, type some text
2. select text with mouse (click and drag)
3. try to paste text with middle mouse button
  
Actual results:
nothing pasted

Expected results:
selected text should be pasted

Additional info:

Comment 1 Matěj Cepl 2011-08-06 15:37:40 UTC
Thanks for the bug report.  We have reviewed the information you have provided above, and there is some additional information we require that will be helpful in our diagnosis of this issue.

Please attach

* your X server config file (/etc/X11/xorg.conf, if available, and any files in /etc/X11/xorg.conf.d/),
* X server log file (/var/log/Xorg.0.log),
* output of the command evtest /dev/input/event<number according to Xorg.0.log), and 
* system log (/var/log/messages)

to the bug report as individual uncompressed file attachments using the bugzilla file attachment link above.

We will review this issue again once you've had a chance to attach this information.

Thanks in advance.

Comment 2 Carl Byington 2011-08-06 18:18:06 UTC
Created attachment 517007 [details]
evtest output

Comment 3 Carl Byington 2011-08-06 18:18:41 UTC
Created attachment 517008 [details]
/var/log/messages

Comment 4 Carl Byington 2011-08-06 18:19:16 UTC
Created attachment 517009 [details]
xorg.conf.d/00-system-setup-keyboard.conf

Comment 5 Carl Byington 2011-08-06 18:20:14 UTC
Created attachment 517010 [details]
xorg.conf.d/99-mouse-midbuttonemulation.conf

I think I manually added this in an attempt to enable the middle mouse button

Comment 6 Carl Byington 2011-08-06 18:20:38 UTC
Created attachment 517012 [details]
Xorg.0.log

Comment 7 Carl Byington 2011-08-06 18:22:11 UTC
Created attachment 517013 [details]
xorg.conf.d/99-mouse-midbuttonemulation.conf

I think I manually added trying to enable the middle button.

Comment 8 Peter Hutterer 2012-04-24 05:14:00 UTC
Please run evtest and press the middle mouse button. Do you see any events show up?

Comment 9 Carl Byington 2012-04-26 04:52:33 UTC
I no longer have access to that hardware mouse

Comment 10 Peter Hutterer 2012-04-26 05:02:19 UTC
Ok, thanks. I'm closing this bug for now, please reopen if it occurs again with other hardware.

Comment 11 Carl Byington 2012-05-09 01:08:14 UTC
I have recovered that mouse, and it is now connected to a fully updated Fedora 16 box. lsusb shows:

Bus 003 Device 002: ID 045e:0084 Microsoft Corp. Basic Optical Mouse

Running evtest, we get events from the left and right buttons, and the scroll wheel up/down, but nothing from pressing the middle (scroll wheel) button.

Event: time 1336525560.021817, type 4 (EV_MSC), code 4 (MSC_SCAN), value 90002
Event: time 1336525560.021819, type 1 (EV_KEY), code 273 (BTN_RIGHT), value 1
Event: time 1336525560.021827, -------------- SYN_REPORT ------------
Event: time 1336525560.157816, type 4 (EV_MSC), code 4 (MSC_SCAN), value 90002
Event: time 1336525560.157818, type 1 (EV_KEY), code 273 (BTN_RIGHT), value 0
Event: time 1336525560.157826, -------------- SYN_REPORT ------------
Event: time 1336525562.589728, type 2 (EV_REL), code 0 (REL_X), value 1
Event: time 1336525562.589733, -------------- SYN_REPORT ------------
Event: time 1336525562.829721, type 2 (EV_REL), code 0 (REL_X), value 1
Event: time 1336525562.829726, -------------- SYN_REPORT ------------
Event: time 1336525563.037719, type 2 (EV_REL), code 1 (REL_Y), value -1
Event: time 1336525563.037723, -------------- SYN_REPORT ------------
Event: time 1336525563.141710, type 2 (EV_REL), code 0 (REL_X), value 1
Event: time 1336525563.141714, -------------- SYN_REPORT ------------

Comment 12 Peter Hutterer 2012-05-09 01:51:49 UTC
not an X bug then. Does the middle button still work on another machine/OS? My guess would be a hardware issue, I don't think the kernel broke that part.

Comment 13 Carl Byington 2012-05-19 17:31:34 UTC
I have not been able to get that middle button to work on any other machine/OS. I agree - it looks like the hardware just broke.

Comment 14 Peter Hutterer 2012-05-20 21:45:19 UTC
Thanks for letting us know. I'll close it as NOTABUG then.


Note You need to log in before you can comment on or make changes to this bug.