Bug 728714 - Version mismatch between package and binary
Summary: Version mismatch between package and binary
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: emacs
Version: 16
Hardware: All
OS: Linux
unspecified
high
Target Milestone: ---
Assignee: Karel Klíč
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-08-06 17:38 UTC by Mike Qin
Modified: 2013-03-03 23:03 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-08-08 13:36:48 UTC


Attachments (Terms of Use)

Description Mike Qin 2011-08-06 17:38:19 UTC
Description of problem:
Version of the package and binary are different for package emacs-23.3-7.fc16.x86_64

How reproducible:

mike@localhost% rpm -qf /usr/bin/emacs
emacs-23.3-7.fc16.x86_64
mike@localhost% emacs --version
GNU Emacs 23.2.1
Copyright (C) 2010 Free Software Foundation, Inc.
GNU Emacs comes with ABSOLUTELY NO WARRANTY.
You may redistribute copies of Emacs
under the terms of the GNU General Public License.
For more information about these matters, see the file named COPYING.

Comment 1 Karel Klíč 2011-08-08 13:04:51 UTC
/usr/bin/emacs is managed by alternatives (see `man alternatives`)

$ ls -l /usr/bin/emacs
lrwxrwxrwx 1 root root 23 May 31 17:20 /usr/bin/emacs -> /etc/alternatives/emacs

$ ls -l /etc/alternatives/emacs
lrwxrwxrwx 1 root root 19 May 31 17:20 /etc/alternatives/emacs -> /usr/bin/emacs-23.2

$ rpm -qf /usr/bin/emacs-23.2
emacs-23.2-11.fc14.i686

Is your /etc/alternatives/emacs symlink pointing to /usr/bin/emacs-23.2 or /usr/bin/emacs-23.3?

Comment 2 Mike Qin 2011-08-08 13:36:48 UTC
Oops, sorry.  I cannot reproduce this either after a yum reinstall...

I encounter this during a yum update from 15 to 16, so emacs-23.2 shouldn't be installed at the same time emacs-23.3 did.  I guess you're right, I didn't notice this was managed by alternatives.  /usr/bin/emacs was pointing to emacs-23.2, which was somehow left there for an unknown reason.

Sorry for the confusion, close the bug.


Note You need to log in before you can comment on or make changes to this bug.