Bug 728752 - Installer hangs: nouveau, PGRAPH: unsupported chipset, please report !
Summary: Installer hangs: nouveau, PGRAPH: unsupported chipset, please report !
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda
Version: 15
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: ---
Assignee: Anaconda Maintenance Team
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: [cat:others]
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-08-07 07:10 UTC by Steve Hedrick
Modified: 2018-04-11 07:59 UTC (History)
10 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-08-07 14:50:33 UTC


Attachments (Terms of Use)

Description Steve Hedrick 2011-08-07 07:10:08 UTC
User-Agent:       Opera/9.80 (Windows NT 6.1; U; Edition Next; en) Presto/2.9.186 Version/12.00

While installing Fedora 15, this dmesg message appears:

[  5.603739] [drm] nouveau 0000:06:00.0: PGRAPH: unsupported chipset, please report ! 

Installation then halted with dracut prompt.

Reproducible: Always

Steps to Reproduce:
1. Attempt to install Fedora 15 with Asus GeForce 590 graphics card
2. Installer halts with unsupported chipset dmesg message twice.
3.
Actual Results:  
The installer halts at the dracut prompt.

Expected Results:  
Installation should have proceeded normally.

My graphics card is Asus GeForce 590. My motherboard is Asus Rampage III Formula.

Comment 1 Matěj Cepl 2011-08-07 20:11:39 UTC
Thanks for the bug report.  We have reviewed the information you have provided above, and there is some additional information especially concerning your hardware we require that will be helpful in our diagnosis of this issue.

You can install Fedora with a basic video driver (see http://docs.fedoraproject.org/en-US/Fedora/15/html/Installation_Guide/
for more information on that). Then after successful installation
 * backup /etc/grub.conf somewhere,
 * remove any occurrence of the word nomodeset, or xdriver=<anything> in the kernel command line (the line starting with the word “kernel”), but add word “text” (unquoted), 
 * restart computer and loging as normal (non-root) user,
 * run command
   startx

It probably fails horribly, but you can collect /var/log/anaconda.xlog, /var/log/Xorg.0.log, and the output of the program dmesg and attach them to this bug report.

Put back nomodeset to the kernel command line and remove text. System should work at least with the basic video (no 3D graphics).

We will review this issue again once you've had a chance to attach this information.

Thank you very much in advance.

Comment 2 Matěj Cepl 2011-08-07 20:12:20 UTC
This might be a better link to the information about installing in the basic-video mode http://docs.fedoraproject.org/en-US/Fedora/15/html/Installation_Guide/sn-boot-menu-x86.html

Comment 3 Steve Hedrick 2011-08-07 22:35:35 UTC
I tried installing Fedora 15 in basic video mode. It crashed to this dmesg message: Dropping to Debug Shell
sh: can't access tty; job control turned off
dracut:/#

I then tried verify and boot mode... same problem.
I tried normal boot install again, same problem as originally.

It's starting to look like the graphics chipset in Asus ENGTX590 graphics card does not like Fedora.

Comment 4 Ben Skeggs 2011-08-07 22:48:09 UTC
No.  The unsupported chipset message will not cause it to halt.  Nouveau will fallback to software rendering in this case.  I believe something else is causing your installer issues.

Comment 5 Matěj Cepl 2011-08-08 05:28:13 UTC
OK, temporarily reassigning to the installer component for further investigation.

Comment 6 Steve Hedrick 2011-08-08 06:44:38 UTC
I reformatted the hard drive and freed up some more space. The installation went well until it was time to configure the LAN interface. With ALL other current Linux distros, the onboard LAN has not worked well with them. This time was no different. 

I was eventually forced to discontinue installation because the onboard LAN would not work with Fedora. I tried to postpone the configuration until I could boot up, but the installer insisted. I will file a new bug on this if you wish.

Comment 7 Chris Lumens 2011-08-08 14:01:43 UTC
If the system with the original problem is still available, please attach the syslog (or output of dmesg) to this bug report.

Comment 8 Pascal Viot 2011-08-31 19:07:39 UTC
I bought a new laptop and I got the message
[    3.195441] [drm] nouveau 0000:01:00.0: Parsing VBIOS init table 1 at offset 0xDC26
[    3.222513] [drm] nouveau 0000:01:00.0: Parsing VBIOS init table 2 at offset 0xEE2C
[    3.222519] [drm] nouveau 0000:01:00.0: Parsing VBIOS init table 3 at offset 0xEE30
[    3.222572] [drm] nouveau 0000:01:00.0: Parsing VBIOS init table 4 at offset 0xEF18
[    3.222575] [drm] nouveau 0000:01:00.0: Parsing VBIOS init table at offset 0xEF7D
[    3.260473] usb 1-1.2: new high speed USB device number 3 using ehci_hcd
[    3.261523] [drm] nouveau 0000:01:00.0: 3 available performance level(s)
[    3.261528] [drm] nouveau 0000:01:00.0: 0: memory 135MHz core 50MHz shader 101MHz voltage 830mV timing 0
[    3.261531] [drm] nouveau 0000:01:00.0: 1: memory 324MHz core 202MHz shader 405MHz voltage 830mV timing 1
[    3.261535] [drm] nouveau 0000:01:00.0: 3: memory 900MHz core 672MHz shader 1344MHz voltage 980mV timing 2
[    3.261654] [TTM] Zone  kernel: Available graphics memory: 1983432 kiB.
[    3.261656] [TTM] Initializing pool allocator.
[    3.261671] [drm] nouveau 0000:01:00.0: Detected 512MiB VRAM
[    3.269787] [drm] nouveau 0000:01:00.0: 512 MiB GART (aperture)
[    3.269796] [drm] nouveau 0000:01:00.0: PGRAPH: unsupported chipset, please report!
[    3.280389] [drm] Supports vblank timestamp caching Rev 1 (10.10.2010).
[    3.280391] [drm] No driver support for vblank timestamp query.
[    3.331482] [drm] nouveau 0000:01:00.0: allocated 1024x768 fb: 0x8020000, bo ffff88014521f000

Comment 9 Fedora End Of Life 2012-08-07 14:50:36 UTC
This message is a notice that Fedora 15 is now at end of life. Fedora
has stopped maintaining and issuing updates for Fedora 15. It is
Fedora's policy to close all bug reports from releases that are no
longer maintained. At this time, all open bugs with a Fedora 'version'
of '15' have been closed as WONTFIX.

(Please note: Our normal process is to give advanced warning of this
occurring, but we forgot to do that. A thousand apologies.)

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, feel free to reopen
this bug and simply change the 'version' to a later Fedora version.

Bug Reporter: Thank you for reporting this issue and we are sorry that
we were unable to fix it before Fedora 15 reached end of life. If you
would still like to see this bug fixed and are able to reproduce it
against a later version of Fedora, you are encouraged to click on
"Clone This Bug" (top right of this page) and open it against that
version of Fedora.

Although we aim to fix as many bugs as possible during every release's
lifetime, sometimes those efforts are overtaken by events. Often a
more recent Fedora release includes newer upstream software that fixes
bugs or makes them obsolete.

The process we are following is described here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping


Note You need to log in before you can comment on or make changes to this bug.