Bug 728813 - Gnuplot is missing the lua terminal in F15
Summary: Gnuplot is missing the lua terminal in F15
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: gnuplot
Version: 15
Hardware: x86_64
OS: Linux
unspecified
unspecified
Target Milestone: ---
Assignee: Peter Schiffer
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-08-07 22:18 UTC by Sato Ichi
Modified: 2011-11-14 22:28 UTC (History)
3 users (show)

Fixed In Version: gnuplot-4.4.2-4.fc15
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-11-14 22:28:03 UTC


Attachments (Terms of Use)

Description Sato Ichi 2011-08-07 22:18:53 UTC
Description of problem: The gnuplot package in Fedora 15 x86_64 is missing the lua/tikz terminal type.


Version-Release number of selected component (if applicable): 4.4.2-3.fc15


How reproducible: Trying to set the gnuplot terminal type to lua results in an error message that there is no such terminal.


Steps to Reproduce:
1. Run gnuplot.
2. In gnuplot enter the command "set terminal lua tikz".

  
Actual results: Get an error message saying "unknown or ambiguous terminal type; type just 'set terminal' for a list". Running "set terminal" does not show lua as one of the available terminal types.


Expected results: Running "set terminal lua tikz" should result in a message saying "Terminal type set to 'lua'". Running "set terminal" should show "lua  Lua PGF/TikZ terminal for LaTeX2e" in the list of available terminals.


Additional info: Adding the --with-lua option to the configure command in the gnuplot.spec file in the source RPM fixes the problem:

# create full version of gnuplot
%configure --with-readline=gnu --with-png --without-linux-vga \
 --enable-history-file --with-lua

Comment 1 Alphonse Steiner 2011-11-01 10:47:26 UTC
I can confirm this bug in FC16, and the fix:
- adding '--with-lua' in the configure of the full version;
- adding 'BuildRequires: lua-devel' in the preamule.

Comment 2 Alphonse Steiner 2011-11-01 11:39:01 UTC
Actually, only the BuildRequires is needed and missing, since lua is enabled by default.

Comment 3 Peter Schiffer 2011-11-04 17:41:57 UTC
rawhide build:
gnuplot-4.4.3-3.fc17
http://koji.fedoraproject.org/koji/buildinfo?buildID=272356

Comment 4 Fedora Update System 2011-11-04 18:00:37 UTC
gnuplot-4.4.3-3.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/gnuplot-4.4.3-3.fc16

Comment 5 Fedora Update System 2011-11-04 19:20:52 UTC
gnuplot-4.4.2-4.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/gnuplot-4.4.2-4.fc15

Comment 6 Fedora Update System 2011-11-04 21:48:10 UTC
Package gnuplot-4.4.3-3.fc16:
* should fix your issue,
* was pushed to the Fedora 16 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing gnuplot-4.4.3-3.fc16'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2011-15425
then log in and leave karma (feedback).

Comment 7 Fedora Update System 2011-11-14 22:28:03 UTC
gnuplot-4.4.3-3.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 8 Fedora Update System 2011-11-14 22:28:57 UTC
gnuplot-4.4.2-4.fc15 has been pushed to the Fedora 15 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.