Bug 728814 - Workspaces and part of search box and application categories displayed offscreen in overview
Summary: Workspaces and part of search box and application categories displayed offscr...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: gnome-shell
Version: 15
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Owen Taylor
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-08-07 22:45 UTC by John Chivall
Modified: 2012-06-04 00:03 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-06-04 00:03:05 UTC


Attachments (Terms of Use)
Screenshot of overview with truncated right edge (910.42 KB, image/png)
2011-08-07 22:45 UTC, John Chivall
no flags Details
Screenshot of overview when left screen is primary (882.01 KB, image/png)
2011-08-07 22:47 UTC, John Chivall
no flags Details
Screenshot of overview with truncated applications menu (922.23 KB, image/png)
2011-08-07 22:47 UTC, John Chivall
no flags Details

Description John Chivall 2011-08-07 22:45:58 UTC
Created attachment 517076 [details]
Screenshot of overview with truncated right edge

Description of problem:
Since a recent update of gnome-shell, the overview is stretched too far too the right, meaning that the search box and the application categories are truncated and the workspace area is not visible at all.

Version-Release number of selected component (if applicable):
3.0.2-4.fc15.x86_64

How reproducible:
Always

Steps to Reproduce:
1. Move pointer to hot corner/press Super/click Activities
2. Click Applications
3. Observe
  
Actual results:
Workspaces area is displayed offscreen. Search box is chopped off at the right. Applications categories are chopped off at right.

Expected results:
Workspaces area is displayed partially onscreen, search box is fully visible, applications menu is fully visible

Additional info:
This problem has only been occurring since a recent update. I have a dual head set up, with the primary screen on the right. With the primary on the left, things are still displayed too far over, but are visible on the right hand monitor (see attached screenshots)

Comment 1 John Chivall 2011-08-07 22:47:04 UTC
Created attachment 517077 [details]
Screenshot of overview when left screen is primary

Comment 2 John Chivall 2011-08-07 22:47:47 UTC
Created attachment 517078 [details]
Screenshot of overview with truncated applications menu

Comment 3 John Chivall 2011-08-07 22:49:33 UTC
This bug persists even with all gnome-shell extensions disabled.

Gnome-shell is obviously calculating the width of the overview incorrectly, yet all other screen components are properly sized, and the mouse cannot move further right than the display edge.

Comment 4 John Chivall 2011-11-21 22:18:27 UTC
Bug seems to be fixed in F16/Gnome 3.2.


Note You need to log in before you can comment on or make changes to this bug.