Bug 728869 - WARNING: at drivers/mtd/nand/r852.c:771 r852_irq+0x6c/0x200 [r852]()
Summary: WARNING: at drivers/mtd/nand/r852.c:771 r852_irq+0x6c/0x200 [r852]()
Keywords:
Status: CLOSED DUPLICATE of bug 798310
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: 15
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Kernel Maintainer List
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-08-08 08:50 UTC by Kamil Páral
Modified: 2012-02-28 18:12 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-02-28 18:12:14 UTC


Attachments (Terms of Use)

Description Kamil Páral 2011-08-08 08:50:52 UTC
Description of problem:
When I plug my 256MB xD card into my card reader, nothing happens (no new disk device appears). When I disconnect it, it occasionally spits this message:

Aug  8 10:40:50 kparal kernel: [  509.334122] r852: detected xD writeable card in slot
Aug  8 10:40:50 kparal kernel: [  509.635137] NAND device: Manufacturer ID: 0x98, Chip ID: 0x71 (Toshiba xD 256MiB 3,3V)
Aug  8 10:41:00 kparal kernel: [  519.344276] r592: IRQ: card added
Aug  8 10:41:00 kparal kernel: [  519.349402] r592: IRQ: card added
Aug  8 10:41:00 kparal kernel: [  519.349411] ------------[ cut here ]------------
Aug  8 10:41:00 kparal kernel: [  519.349439] WARNING: at drivers/mtd/nand/r852.c:771 r852_irq+0x6c/0x200 [r852]()
Aug  8 10:41:00 kparal kernel: [  519.349445] Hardware name: 2241B48
Aug  8 10:41:00 kparal kernel: [  519.349449] Modules linked in: mtdchar tun usb_storage uas fuse ip6table_filter ip6_tables ebtable_nat ebtables ipt_MASQUERADE iptable_nat nf_nat nf_conntrack_ipv4 nf_defrag_ipv4 xt_state nf_conntrack xt_CHECKSUM iptable_mangle bridge stp llc ppdev parport_pc lp parport nfsd lockd nfs_acl auth_rpcgss sunrpc cpufreq_ondemand acpi_cpufreq freq_table mperf rfcomm bnep btusb bluetooth arc4 snd_hda_codec_conexant iwlagn snd_hda_intel mac80211 snd_hda_codec snd_hwdep r852 sm_common nand uvcvideo cfg80211 snd_seq snd_seq_device i2c_i801 iTCO_wdt r592 nand_ids nand_ecc mtd videodev memstick snd_pcm iTCO_vendor_support media v4l2_compat_ioctl32 e1000e thinkpad_acpi snd_timer snd_page_alloc snd microcode rfkill joydev soundcore virtio_net kvm_intel kvm sha256_generic dm_crypt sdhci_pci sdhci mmc_core firewire_ohci firewire_core crc_itu_t yenta_socket wmi i915 drm_kms_helper drm i2c_algo_bit i2c_core video [last unloaded: scsi_wait_scan]
Aug  8 10:41:00 kparal kernel: [  519.349615] Pid: 0, comm: kworker/0:0 Tainted: G        W   2.6.40-4.fc15.x86_64 #1
Aug  8 10:41:00 kparal kernel: [  519.349621] Call Trace:
Aug  8 10:41:00 kparal kernel: [  519.349625]  <IRQ>  [<ffffffff81054c8e>] warn_slowpath_common+0x83/0x9b
Aug  8 10:41:00 kparal kernel: [  519.349651]  [<ffffffff81054cc0>] warn_slowpath_null+0x1a/0x1c
Aug  8 10:41:00 kparal kernel: [  519.349663]  [<ffffffffa01be623>] r852_irq+0x6c/0x200 [r852]
Aug  8 10:41:00 kparal kernel: [  519.349674]  [<ffffffff810adddc>] handle_irq_event_percpu+0x53/0x1a5
Aug  8 10:41:00 kparal kernel: [  519.349682]  [<ffffffff810adf66>] handle_irq_event+0x38/0x56
Aug  8 10:41:00 kparal kernel: [  519.349691]  [<ffffffff810b004e>] handle_fasteoi_irq+0x77/0x9b
Aug  8 10:41:00 kparal kernel: [  519.349701]  [<ffffffff8100ab6d>] handle_irq+0x88/0x8e
Aug  8 10:41:00 kparal kernel: [  519.349711]  [<ffffffff814bf21d>] do_IRQ+0x4d/0xa5
Aug  8 10:41:00 kparal kernel: [  519.349721]  [<ffffffff814b7413>] common_interrupt+0x13/0x13
Aug  8 10:41:00 kparal kernel: [  519.349726]  <EOI>  [<ffffffff812abfab>] ? arch_local_irq_enable+0x8/0xd
Aug  8 10:41:00 kparal kernel: [  519.349746]  [<ffffffff810754e5>] ? sched_clock_idle_wakeup_event+0x17/0x1a
Aug  8 10:41:00 kparal kernel: [  519.349754]  [<ffffffff812acb9f>] acpi_idle_enter_bm+0x21d/0x255
Aug  8 10:41:00 kparal kernel: [  519.349766]  [<ffffffff813b0aa5>] cpuidle_idle_call+0xd7/0x168
Aug  8 10:41:00 kparal kernel: [  519.349777]  [<ffffffff81008307>] cpu_idle+0xa5/0xdf
Aug  8 10:41:00 kparal kernel: [  519.349786]  [<ffffffff814a6628>] start_secondary+0x23f/0x241
Aug  8 10:41:00 kparal kernel: [  519.349793] ---[ end trace 9641499d6eb1bd75 ]---
Aug  8 10:41:00 kparal kernel: [  519.444179] r852: card removed


Version-Release number of selected component (if applicable):
Linux kparal 2.6.40-4.fc15.x86_64 #1 SMP Fri Jul 29 18:46:53 UTC 2011 x86_64 x86_64 x86_64 GNU/Linux
My hardware: http://smolt.fedoraproject.org/show?uuid=pub_46e92a8f-2fad-4ef2-b610-c88f04d8cde6

How reproducible:
the drive is never attached, the error message is spit out occasionally

Comment 1 Josh Boyer 2011-09-29 11:50:17 UTC
Is this a multi-slot card reader style device?  It seems the memstick r592 and MTD r852 drivers are somehow racing on a card insertion.  What happens if you blacklist one or the other?

Comment 2 Kamil Páral 2011-10-05 11:01:47 UTC
It is an integrated card reader that can read multiple types of cards.

When I do "modprobe -r r592" (and ensure by lsmod it is no longer loaded), then push the card in and out, I get the following messages:

Oct  5 12:57:35 kparal kernel: [  136.168294] r592 0000:15:00.4: PCI INT C disabled
Oct  5 12:57:50 kparal kernel: [  150.747143] r852: detected xD writeable card in slot
Oct  5 12:57:50 kparal kernel: [  151.048213] NAND device: Manufacturer ID: 0x98, Chip ID: 0x71 (Toshiba xD 256MiB 3,3V)
Oct  5 12:57:50 kparal kernel: [  151.098408] NMI: PCI system error (SERR) for reason b1 on CPU 0.
Oct  5 12:57:50 kparal kernel: [  151.098411] DRHD: handling fault status reg 3
Oct  5 12:57:50 kparal kernel: [  151.098414] DMAR:[DMA Write] Request device [00:1e.0] fault addr fffeb000 
Oct  5 12:57:50 kparal kernel: [  151.098415] DMAR:[fault reason 02] Present bit in context entry is clear

Message from syslogd@kparal at Oct  5 12:57:50 ...
 kernel:[  151.098408] NMI: PCI system error (SERR) for reason b1 on CPU 0.
Oct  5 12:57:50 kparal kernel: [  151.098418] Dazed and confused, but trying to continue

Message from syslogd@kparal at Oct  5 12:57:50 ...
 kernel:[  151.098418] Dazed and confused, but trying to continue
Oct  5 12:58:15 kparal kernel: [  176.285035] r852: card removed
Oct  5 12:58:16 kparal kernel: [  177.367383] irq 18: nobody cared (try booting with the "irqpoll" option)
Oct  5 12:58:16 kparal kernel: [  177.367397] Pid: 0, comm: swapper Not tainted 2.6.40.4-5.fc15.x86_64 #1
Oct  5 12:58:16 kparal kernel: [  177.367403] Call Trace:
Oct  5 12:58:16 kparal kernel: [  177.367408]  <IRQ>  [<ffffffff810af820>] __report_bad_irq+0x38/0xc3
Oct  5 12:58:16 kparal kernel: [  177.367432]  [<ffffffff810afab7>] note_interrupt+0x173/0x1f0
Oct  5 12:58:16 kparal kernel: [  177.367442]  [<ffffffff810ae0ee>] handle_irq_event_percpu+0x15d/0x1a5
Oct  5 12:58:16 kparal kernel: [  177.367450]  [<ffffffff810ae16e>] handle_irq_event+0x38/0x56
Oct  5 12:58:16 kparal kernel: [  177.367459]  [<ffffffff810b0256>] handle_fasteoi_irq+0x77/0x9b
Oct  5 12:58:16 kparal kernel: [  177.367469]  [<ffffffff8100ab6d>] handle_irq+0x88/0x8e
Oct  5 12:58:16 kparal kernel: [  177.367479]  [<ffffffff8149029d>] do_IRQ+0x4d/0xa5
Oct  5 12:58:16 kparal kernel: [  177.367490]  [<ffffffff81488493>] common_interrupt+0x13/0x13
Oct  5 12:58:16 kparal kernel: [  177.367495]  <EOI>  [<ffffffff812ac647>] ? arch_local_irq_enable+0x8/0xd
Oct  5 12:58:16 kparal kernel: [  177.367515]  [<ffffffff81075651>] ? sched_clock_idle_wakeup_event+0x17/0x1a
Oct  5 12:58:16 kparal kernel: [  177.367524]  [<ffffffff812ad33f>] acpi_idle_enter_simple+0xcc/0x102
Oct  5 12:58:16 kparal kernel: [  177.367536]  [<ffffffff813af949>] cpuidle_idle_call+0xd7/0x168
Oct  5 12:58:16 kparal kernel: [  177.367547]  [<ffffffff81008307>] cpu_idle+0xa5/0xdf
Oct  5 12:58:16 kparal kernel: [  177.367558]  [<ffffffff8146741e>] rest_init+0x72/0x74
Oct  5 12:58:16 kparal kernel: [  177.367569]  [<ffffffff81b66b8b>] start_kernel+0x3ca/0x3d5
Oct  5 12:58:16 kparal kernel: [  177.367578]  [<ffffffff81b662c4>] x86_64_start_reservations+0xaf/0xb3
Oct  5 12:58:16 kparal kernel: [  177.367586]  [<ffffffff81b66140>] ? early_idt_handlers+0x140/0x140

Message from syslogd@kparal at Oct  5 12:58:16 ...
 kernel:[  177.367659] Disabling IRQ #18
Oct  5 12:58:16 kparal kernel: [  177.367595]  [<ffffffff81b663ca>] x86_64_start_kernel+0x102/0x111
Oct  5 12:58:16 kparal kernel: [  177.367600] handlers:
Oct  5 12:58:16 kparal kernel: [  177.367608] [<ffffffff813501b0>] usb_hcd_irq
Oct  5 12:58:16 kparal kernel: [  177.367643] [<ffffffffa00f79d7>] sdhci_irq
Oct  5 12:58:16 kparal kernel: [  177.367654] [<ffffffffa023f5b7>] r852_irq
Oct  5 12:58:16 kparal kernel: [  177.367659] Disabling IRQ #18


When I pushed it in and out more times, I got a kernel panic and had to hard-reboot.

Linux kparal 2.6.40.4-5.fc15.x86_64 #1 SMP Tue Aug 30 14:38:32 UTC 2011 x86_64 x86_64 x86_64 GNU/Linux

Comment 3 Kamil Páral 2011-10-05 11:13:12 UTC
When I do "modprobe -r r852", nothing happens. There is only a line "card added" printed out when I *pull out* the card.


Oct  5 13:11:19 kparal kernel: [  402.681360] r852 0000:15:00.5: PCI INT C disabled
Oct  5 13:11:53 kparal kernel: [  436.310754] r592: IRQ: card added
Oct  5 13:11:53 kparal kernel: [  436.316120] r592: IRQ: card added
Oct  5 13:12:00 kparal kernel: [  443.534205] r592: IRQ: card added
Oct  5 13:12:07 kparal kernel: [  450.743411] r592: IRQ: card added
Oct  5 13:12:12 kparal kernel: [  455.190395] r592: IRQ: card added

Comment 4 Josh Boyer 2012-02-28 18:12:14 UTC
Duping this to the newest kernel report

*** This bug has been marked as a duplicate of bug 798310 ***


Note You need to log in before you can comment on or make changes to this bug.