Bug 728896 - gnome-display-properties should not allow setting 3 or more multiple monitors when not possible
Summary: gnome-display-properties should not allow setting 3 or more multiple monitors...
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: control-center
Version: 6.2
Hardware: i686
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Rui Matos
QA Contact: Desktop QE
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-08-08 10:31 UTC by Vitezslav Humpa
Modified: 2017-12-06 12:03 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-12-06 12:03:21 UTC


Attachments (Terms of Use)
xorg.conf which almost works (1.84 KB, text/plain)
2013-11-22 10:29 UTC, trev.g7pvs
no flags Details

Description Vitezslav Humpa 2011-08-08 10:31:43 UTC
Description of problem:
When there are three or more displays present in the system, only two can be set active at the same time. However gnome-display-properties allows for enabling all of them, with the one most recently activated not working.

If this is not possible by design (e.g. only two are supported, due to limited crtc channels etc.), the config tool should prohibit this.

Version-Release number of selected component (if applicable):
control-center-2.28.1-25.el6

How reproducible:
Always when setting multihead for more displays than channels present

Steps to Reproduce:
1. Have more than two displays present (likely with two of them connected through the same channel). (Laptop LCD + two monitors connected to the dockstation in my case)
2. Try to enable all of them in any relative position
  
Actual results:
Only two monitors will be active at any time

Expected results:
All three active, or the gnome-display-properties not allowing or warning not to do this.

Additional info:

Comment 1 Ray Strode [halfline] 2011-12-19 19:42:32 UTC
can you give a little more detail on what you would like the interaction to be like?

Comment 4 trev.g7pvs 2013-11-22 10:29:47 UTC
Created attachment 827669 [details]
xorg.conf which almost works

I've just upgraded from fc18 to fc19 and my previous xorg.conf would allow 4 monitors (although it would only allow a configuration of all 4 in a row - which isn't how they are physically positioned!)

fc19 displayed 4 blank screens when started with original xorg.conf.

deleting xorg.conf allows 2 working monitors and two blank monitors, although the computer locks up due to some sort of display bug.

With the attached xorg.conf I can move the mouse between the 4 monitors, however only the top two have graphics, the bottom two (furthest left in config) are black and although the mouse shows a pointer when on those displays a window cannot be dragged to those displays.

With the current xorg.conf running the display settings gui only shows the top two monitors.  With no xorg.conf all 4 monitors were shown in display settings, however only the top two worked and messing about with the settings would lockup the computer.

Comment 5 Jan Kurik 2017-12-06 12:03:21 UTC
Red Hat Enterprise Linux 6 is in the Production 3 Phase. During the Production 3 Phase, Critical impact Security Advisories (RHSAs) and selected Urgent Priority Bug Fix Advisories (RHBAs) may be released as they become available.

The official life cycle policy can be reviewed here:

http://redhat.com/rhel/lifecycle

This issue does not meet the inclusion criteria for the Production 3 Phase and will be marked as CLOSED/WONTFIX. If this remains a critical requirement, please contact Red Hat Customer Support to request a re-evaluation of the issue, citing a clear business justification. Note that a strong business justification will be required for re-evaluation. Red Hat Customer Support can be contacted via the Red Hat Customer Portal at the following URL:

https://access.redhat.com/


Note You need to log in before you can comment on or make changes to this bug.