Bug 728906 - RHEVH ovirt log show the RHN password in plaintext.
Summary: RHEVH ovirt log show the RHN password in plaintext.
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: ovirt-node
Version: 6.2
Hardware: x86_64
OS: Linux
medium
medium
Target Milestone: rc
: ---
Assignee: Joey Boggs
QA Contact: Virtualization Bugs
URL:
Whiteboard:
: 736404 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-08-08 11:03 UTC by cshao
Modified: 2011-12-06 19:26 UTC (History)
8 users (show)

Fixed In Version: ovirt-node-2.0.2-0.1.git5dce5f9.el6
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-12-06 19:26:05 UTC


Attachments (Terms of Use)
ovirt.log (26.47 KB, text/plain)
2011-08-08 11:03 UTC, cshao
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2011:1783 normal SHIPPED_LIVE rhev-hypervisor6 bug fix and enhancement update 2011-12-06 15:10:54 UTC

Description cshao 2011-08-08 11:03:43 UTC
Created attachment 517167 [details]
ovirt.log

Description of problem:
RHEVH ovirt log show the RHN password in plaintext.

Version-Release number of selected component (if applicable):
rhev-hypervisor-6.2-0.11.el6

How reproducible:
100%

Steps to Reproduce:
1. Select 'Red Hat Network' in TUI.
2. Select 'Register to RHN Satellite.
3. Input valid information.
4. less /var/log/ovirt.log
  
Actual results:
RHEVH ovirt log show the RHN password in plaintext.

{'breth0': ('10.66.10.19', 'fe80::f24d:a2ff:fe24:d2ea')}current page: 15
RHN Config does not exist
Registering to RHN account.....
 --username qa@redhat.com --password Q3BrX5tFFAd10G  --novirtinfo --norhnsd --nopackages --force
Warning: yum-rhn-plugin is not present, could not enable it.
File persisted

Expected results:
RHEVH ovirt log should not show the RHN password in plaintext.

Additional info:

Comment 4 cshao 2011-08-30 02:41:45 UTC
Test version:
rhev-hypervisor-6.2-0.14.el6

ovirt.log
==============================
Registering to RHN account.....
 --serverUrl https://10.66.73.127/XMLRPC --sslCACert /etc/sysconfig/rhn/RHN-ORG-TRUSTED-SSL-CERT --username 'ycui@redhat.com' --password 'XXXXXXXX'  --proxy=: --novirtinfo --norhnsd --nopackages --force

So change bug status to VERIFIED.

Comment 5 Joey Boggs 2011-09-07 20:44:02 UTC
*** Bug 736404 has been marked as a duplicate of this bug. ***

Comment 6 errata-xmlrpc 2011-12-06 19:26:05 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2011-1783.html


Note You need to log in before you can comment on or make changes to this bug.