Bug 72893 - hpux/solaris changes
hpux/solaris changes
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: rpm (Show other bugs)
8.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Paul Nasrat
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-08-28 16:08 EDT by Jeff Johnson
Modified: 2007-04-18 12:46 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-06-07 17:07:08 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jeff Johnson 2002-08-28 16:08:05 EDT
I'm having trouble compiling the latest version for hpux 11.11 and solaris
2.8

Both compiles fail at the same point:

gcc -DHAVE_CONFIG_H -I. -I. -I.. -I. -I.. -I../popt -I../zlib -g -O2
-D_GNU_SOURCE -D_REENTRANT -Wall -Wpointer-arith -Wstrict-prototypes
-Wmissing-prototypes -Wno-char-subscripts -c fts.c -MT fts.lo -MD -MP -MF
.deps/fts.TPlo  -fPIC -DPIC -o .libs/fts.lo
cc1: warning: changing search order for system directory "."
cc1: warning:   as it has already been specified as a non-system directory
In file included from fts.c:49:
fts.h:35:22: features.h: No such file or directory
In file included from fts.c:49:
fts.h:162: syntax error before "FTSENT"
fts.h:162: parse error before "__THROW"
fts.h:164: warning: type defaults to `int' in declaration of `__THROW'
fts.h:164: warning: data definition has no type or storage class
fts.h:172: parse error before "__THROW"
fts.h:174: warning: type defaults to `int' in declaration of `__THROW'
fts.h:174: warning: data definition has no type or storage class
fts.h:186: parse error before "__THROW"
fts.h:187: warning: type defaults to `int' in declaration of `__THROW'
fts.h:187: warning: data definition has no type or storage class
fts.h:195: parse error before "__THROW"
fts.h:197: warning: type defaults to `int' in declaration of `__THROW'
fts.h:197: warning: data definition has no type or storage class
fts.h:207: parse error before "__THROW"
fts.h:208: warning: type defaults to `int' in declaration of `__THROW'
fts.h:208: warning: data definition has no type or storage class

features.h seems to be some file from glibc, as far as I know.

hpux has some other minor problems in beecrypt:

cat config.h | grep -v HAVE_SYNCH_H >config.h.tmp

needs to be applied or beecrypt will try to use DEFAULTMUTEX (which is not
defined) instead of PTHREAD_MUTEX_INITIALIZER

cat Makefile | sed "s,-I$,,g" >Makefile.tmp
.. here's an empty include that is added to CFLAGS
mkdir zlib
.. -L ./zlib is included in the commandline for linking, if the directory
does not exist linking falis
Comment 1 Jeff Johnson 2002-08-30 09:27:41 EDT
Code is mostly fixed, autocrap still will need
some work, but I compiled on hpux yesterday
without too much pain. On to solaris ...
Comment 2 Paul Nasrat 2005-06-07 17:07:08 EDT
Closing due to lack of activity.

HP-UX rpm can be found at http://www.openpkg.org/ 

Please reopen with patches against HEAD or rpm 4.4.x or send patches to
rpm-devel list

https://lists.dulug.duke.edu/mailman/listinfo/rpm-devel

Note You need to log in before you can comment on or make changes to this bug.