Bug 728977 - matahari-host agent coredumps when connected broker stops
Summary: matahari-host agent coredumps when connected broker stops
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: matahari
Version: 6.2
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: rc
: ---
Assignee: Zane Bitter
QA Contact: Dave Johnson
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-08-08 14:31 UTC by Dave Johnson
Modified: 2011-12-06 11:39 UTC (History)
5 users (show)

Fixed In Version: matahari-0.4.2-5.el6
Doc Type: Bug Fix
Doc Text:
No description needed
Clone Of:
Environment:
Last Closed: 2011-12-06 11:39:27 UTC


Attachments (Terms of Use)
hostd coredump (8.26 MB, application/octet-stream)
2011-08-08 14:31 UTC, Dave Johnson
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2011:1569 normal SHIPPED_LIVE matahari bug fix and enhancement update 2011-12-06 00:39:06 UTC

Description Dave Johnson 2011-08-08 14:31:11 UTC
Created attachment 517234 [details]
hostd coredump

Description of problem:
=======================
When you have a matahari host agent connected to a broker and then stop the broker, the host agent core dumps.  The other agents continue to run.

Aug  8 10:20:09 hp-dl2x170g6-02 abrt[11722]: saved core dump of pid 11654 (/usr/sbin/matahari-qmf-hostd) to /var/spool/abrt/ccpp-1312813209-11654.new/coredump (8794112 bytes)
Aug  8 10:20:09 hp-dl2x170g6-02 abrtd: Directory 'ccpp-1312813209-11654' creation detected
Aug  8 10:20:09 hp-dl2x170g6-02 abrtd: Crash is in database already (dup of /var/spool/abrt/ccpp-1312811415-11317)
Aug  8 10:20:09 hp-dl2x170g6-02 abrtd: Deleting crash ccpp-1312813209-11654 (dup of ccpp-1312811415-11317), sending dbus signal
"/var/log/messages" 56L, 7337C                                                      

Version-Release number of selected component (if applicable):
=============================================================
matahari-host-0.4.2-2.el6.x86_64

How reproducible:
=================
100%

Steps to Reproduce:
===================
1.  install matahari broker and agents
2.  start broker and agents
3.  tail /var/log/messages
4.  stop broker
5.  see message indicating host agent crashes

  
Actual results:
===============
core dump

Expected results:
==================
agent continues to run

Comment 2 Zane Bitter 2011-08-10 15:05:44 UTC
Patch sent to upstream mailing list.

Comment 4 Dave Johnson 2011-08-16 22:15:29 UTC
good 2 go with v0.4.2-6

Comment 5 Russell Bryant 2011-11-16 21:29:57 UTC
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
No description needed

Comment 6 errata-xmlrpc 2011-12-06 11:39:27 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2011-1569.html


Note You need to log in before you can comment on or make changes to this bug.