Bug 728988 - matahari agents fail to reconnect after broker restarted
Summary: matahari agents fail to reconnect after broker restarted
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: matahari
Version: 6.2
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: rc
: ---
Assignee: Zane Bitter
QA Contact: Dave Johnson
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-08-08 15:00 UTC by Dave Johnson
Modified: 2011-12-06 11:39 UTC (History)
5 users (show)

Fixed In Version: matahari-0.4.2-5.el6
Doc Type: Bug Fix
Doc Text:
No description needed
Clone Of:
Environment:
Last Closed: 2011-12-06 11:39:29 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2011:1569 normal SHIPPED_LIVE matahari bug fix and enhancement update 2011-12-06 00:39:06 UTC

Description Dave Johnson 2011-08-08 15:00:24 UTC
Description of problem:
=======================
When agents are connected to a broker and the broker gets stopped, I would expect that the agents would then fall back to the --reconnect code and begin attempting to reconnect to the broker.

Instead, this does not happen and when the broker is finally restarted, the running agent does not connect, is "orphaned", and requires a restart of its own.

Version-Release number of selected component (if applicable):
=============================================================
matahari-0.4.2-2.el6.x86_64
matahari-agent-lib-0.4.2-2.el6.x86_64
matahari-broker-0.4.2-2.el6.x86_64
matahari-host-0.4.2-2.el6.x86_64
matahari-lib-0.4.2-2.el6.x86_64
matahari-network-0.4.2-2.el6.x86_64
matahari-service-0.4.2-2.el6.x86_64
matahari-sysconfig-0.4.2-2.el6.x86_64


How reproducible:
==================
100%


Steps to Reproduce:
===================
1.  install matahari broker and agents
2.  start  matahari broker and agents
3.  restart broker
4.  ps -ef | grep matahari, see agents running
5.  qmf-tool localhost:49000, list agents, see no agents connected

Comment 2 Zane Bitter 2011-08-10 15:06:50 UTC
Patch posted to upstream mailing list.

Comment 4 Dave Johnson 2011-08-16 22:26:57 UTC
good 2 go in v0.4.2-6

Comment 5 Russell Bryant 2011-11-16 21:31:51 UTC
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
No description needed

Comment 6 errata-xmlrpc 2011-12-06 11:39:29 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2011-1569.html


Note You need to log in before you can comment on or make changes to this bug.