Bug 728994 - SELinux is preventing /usr/sbin/lircd from 'read' accesses on the file busnum.
Summary: SELinux is preventing /usr/sbin/lircd from 'read' accesses on the file busnum.
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: selinux-policy
Version: 15
Hardware: x86_64
OS: Linux
unspecified
medium
Target Milestone: ---
Assignee: Miroslav Grepl
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: setroubleshoot_trace_hash:fae7ce44ddb...
: 729048 729049 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-08-08 15:18 UTC by Jan Willies
Modified: 2011-09-07 00:18 UTC (History)
3 users (show)

Fixed In Version: selinux-policy-3.9.16-38.fc15
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-09-07 00:18:19 UTC


Attachments (Terms of Use)

Description Jan Willies 2011-08-08 15:18:27 UTC
SELinux is preventing /usr/sbin/lircd from 'read' accesses on the file busnum.

*****  Plugin catchall (100. confidence) suggests  ***************************

If you believe that lircd should be allowed read access on the busnum file by default.
Then you should report this as a bug.
You can generate a local policy module to allow this access.
Do
allow this access for now by executing:
# grep lircd /var/log/audit/audit.log | audit2allow -M mypol
# semodule -i mypol.pp

Additional Information:
Source Context                system_u:system_r:lircd_t:s0
Target Context                system_u:object_r:sysfs_t:s0
Target Objects                busnum [ file ]
Source                        lircd
Source Path                   /usr/sbin/lircd
Port                          <Unbekannt>
Host                          (removed)
Source RPM Packages           lirc-0.9.0-7.fc15
Target RPM Packages           
Policy RPM                    selinux-policy-3.9.16-35.fc15
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Enforcing
Host Name                     (removed)
Platform                      Linux (removed) 2.6.40-4.fc15.x86_64 #1 SMP Fri Jul
                              29 18:46:53 UTC 2011 x86_64 x86_64
Alert Count                   1
First Seen                    Mo 08 Aug 2011 17:17:42 CEST
Last Seen                     Mo 08 Aug 2011 17:17:42 CEST
Local ID                      78f79100-8380-4c8a-93cf-043019aa8a03

Raw Audit Messages
type=AVC msg=audit(1312816662.280:674): avc:  denied  { read } for  pid=1065 comm="lircd" name="busnum" dev=sysfs ino=11266 scontext=system_u:system_r:lircd_t:s0 tcontext=system_u:object_r:sysfs_t:s0 tclass=file


type=SYSCALL msg=audit(1312816662.280:674): arch=x86_64 syscall=open success=no exit=EACCES a0=7fffea426bb0 a1=0 a2=1b6 a3=9 items=0 ppid=1 pid=1065 auid=4294967295 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 tty=(none) ses=4294967295 comm=lircd exe=/usr/sbin/lircd subj=system_u:system_r:lircd_t:s0 key=(null)

Hash: lircd,lircd_t,sysfs_t,file,read

audit2allow

#============= lircd_t ==============
allow lircd_t sysfs_t:file read;

audit2allow -R

#============= lircd_t ==============
allow lircd_t sysfs_t:file read;

Comment 1 Daniel Walsh 2011-08-08 15:34:34 UTC
*** Bug 729048 has been marked as a duplicate of this bug. ***

Comment 2 Daniel Walsh 2011-08-08 15:34:53 UTC
*** Bug 729049 has been marked as a duplicate of this bug. ***

Comment 3 Miroslav Grepl 2011-08-10 07:32:58 UTC
Fixed in the next f15 release.

Comment 4 Fedora Update System 2011-08-11 20:39:12 UTC
selinux-policy-3.9.16-38.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/selinux-policy-3.9.16-38.fc15

Comment 5 Fedora Update System 2011-08-12 18:19:51 UTC
Package selinux-policy-3.9.16-38.fc15:
* should fix your issue,
* was pushed to the Fedora 15 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing selinux-policy-3.9.16-38.fc15'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/selinux-policy-3.9.16-38.fc15
then log in and leave karma (feedback).

Comment 6 Fedora Update System 2011-09-07 00:16:58 UTC
selinux-policy-3.9.16-38.fc15 has been pushed to the Fedora 15 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.