Bug 729048 - SELinux is preventing /usr/sbin/lircd from 'open' accesses on the file busnum.
Summary: SELinux is preventing /usr/sbin/lircd from 'open' accesses on the file busnum.
Keywords:
Status: CLOSED DUPLICATE of bug 728994
Alias: None
Product: Fedora
Classification: Fedora
Component: selinux-policy
Version: 15
Hardware: x86_64
OS: Linux
unspecified
medium
Target Milestone: ---
Assignee: Miroslav Grepl
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: setroubleshoot_trace_hash:c8da46de8b1...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-08-08 15:21 UTC by Jan Willies
Modified: 2011-08-08 15:34 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-08-08 15:34:34 UTC


Attachments (Terms of Use)

Description Jan Willies 2011-08-08 15:21:52 UTC
SELinux is preventing /usr/sbin/lircd from 'open' accesses on the file busnum.

*****  Plugin catchall (100. confidence) suggests  ***************************

If you believe that lircd should be allowed open access on the busnum file by default.
Then you should report this as a bug.
You can generate a local policy module to allow this access.
Do
allow this access for now by executing:
# grep lircd /var/log/audit/audit.log | audit2allow -M mypol
# semodule -i mypol.pp

Additional Information:
Source Context                system_u:system_r:lircd_t:s0
Target Context                system_u:object_r:sysfs_t:s0
Target Objects                busnum [ file ]
Source                        lircd
Source Path                   /usr/sbin/lircd
Port                          <Unbekannt>
Host                          (removed)
Source RPM Packages           lirc-0.9.0-7.fc15
Target RPM Packages           
Policy RPM                    selinux-policy-3.9.16-35.fc15
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Enforcing
Host Name                     (removed)
Platform                      Linux (removed) 2.6.40-4.fc15.x86_64 #1 SMP Fri Jul
                              29 18:46:53 UTC 2011 x86_64 x86_64
Alert Count                   1
First Seen                    Mo 08 Aug 2011 17:20:30 CEST
Last Seen                     Mo 08 Aug 2011 17:20:30 CEST
Local ID                      b98af8d7-421e-4fed-a542-bd5574c53599

Raw Audit Messages
type=AVC msg=audit(1312816830.315:683): avc:  denied  { open } for  pid=1065 comm="lircd" name="busnum" dev=sysfs ino=11266 scontext=system_u:system_r:lircd_t:s0 tcontext=system_u:object_r:sysfs_t:s0 tclass=file


type=SYSCALL msg=audit(1312816830.315:683): arch=x86_64 syscall=open success=no exit=EACCES a0=7fffea426bb0 a1=0 a2=1b6 a3=9 items=0 ppid=1 pid=1065 auid=4294967295 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 tty=(none) ses=4294967295 comm=lircd exe=/usr/sbin/lircd subj=system_u:system_r:lircd_t:s0 key=(null)

Hash: lircd,lircd_t,sysfs_t,file,open

audit2allow

#============= lircd_t ==============
allow lircd_t sysfs_t:file open;

audit2allow -R

#============= lircd_t ==============
allow lircd_t sysfs_t:file open;

Comment 1 Daniel Walsh 2011-08-08 15:34:34 UTC

*** This bug has been marked as a duplicate of bug 728994 ***


Note You need to log in before you can comment on or make changes to this bug.