Bug 729059 - sudo package has superfluous dependency to perl
Summary: sudo package has superfluous dependency to perl
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: sudo
Version: 16
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Daniel Kopeček
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-08-08 15:56 UTC by Mads Kiilerich
Modified: 2011-11-14 00:50 UTC (History)
2 users (show)

Fixed In Version: sudo-1.8.3p1-1.fc16
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-11-14 00:50:19 UTC


Attachments (Terms of Use)

Description Mads Kiilerich 2011-08-08 15:56:40 UTC
The sudo rpm requires perl, but the only reference to perl seems to be /usr/share/doc/*/sudoers2ldif - which is doc and shouldn't cause dependencies.

That seems to be the most high-profile user of perl in Fedora and do thus cause 30 MB unnecessary installation. That is especially an issue on live cd's where sudo can be convenient to work around security when it isn't relevant.

Comment 1 Fedora Update System 2011-11-10 10:06:10 UTC
sudo-1.8.3p1-1.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/sudo-1.8.3p1-1.fc16

Comment 2 Fedora Update System 2011-11-11 01:26:56 UTC
Package sudo-1.8.3p1-1.fc16:
* should fix your issue,
* was pushed to the Fedora 16 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing sudo-1.8.3p1-1.fc16'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2011-15761
then log in and leave karma (feedback).

Comment 3 Fedora Update System 2011-11-14 00:50:19 UTC
sudo-1.8.3p1-1.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.