Bug 729061 - [RHEL6] Fix unmap typo bug in mstflint
Summary: [RHEL6] Fix unmap typo bug in mstflint
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: mstflint
Version: 6.1
Hardware: x86_64
OS: Linux
medium
medium
Target Milestone: rc
: ---
Assignee: Doug Ledford
QA Contact: Infiniband QE
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-08-08 15:59 UTC by Travis Gummels
Modified: 2018-11-14 11:30 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-12-06 15:33:40 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2011:1639 normal SHIPPED_LIVE RDMA stack bug fix and enhancement update 2011-12-06 00:50:39 UTC

Description Travis Gummels 2011-08-08 15:59:21 UTC
Description of problem:

We use mstflint to query IB firmware, when I query the IB card I see this in the console logs

mstflint:11565 freeing invalid memtype dff00000-dff10000
mstflint:11565 freeing invalid memtype dff10000-e0000000

Command used is

mstflint -d 07:00.0 q
Image type:      ConnectX
FW Version:      2.8.600
Device ID:       25418
Chip Revision:   A0
Description:     Node             Port1            Port2            Sys image
GUIDs:           0002c9020025feb4 0002c9020025feb5 0002c9020025feb6 
0002c9020025feb7 
MACs:                                 0002c925feb5     0002c925feb6
Board ID:         (MT_04A0110002)
VSD:             
PSID:            MT_04A0110002

Version-Release number of selected component (if applicable):
rpm -q mstflint
mstflint-1.4-3.el6.x86_64

How reproducible:
100%

Steps to Reproduce:
1.mstflint -d 07:00.0 q

  
Actual results:
Following in messages
mstflint:11565 freeing invalid memtype dff00000-dff10000
mstflint:11565 freeing invalid memtype dff10000-e0000000

Expected results:
No garbage.

Additional info:

http://git.openfabrics.org/git?p=~orenk/mstflint.git;a=commit;h=771c3d04c9a09a83c182037663032b1f53dbf87b

Fix unmap typo bug

author	Oren Kladnitsky <orenk@dev.mellanox.co.il>	
	 Mon, 22 Mar 2010 15:49:13 +0000 (17:49 +0200)
committer	Oren Kladnitsky <orenk@dev.mellanox.co.il>	
	 Mon, 22 Mar 2010 15:49:13 +0000 (17:49 +0200)
commit	771c3d04c9a09a83c182037663032b1f53dbf87b
tree	79ff1e8b617c0c898de5d9d2be9c56f3f596e354	
parent	9ce54e17f1493650d0a0f9ddb837fd3f4b951114	

Fix unmap typo bug

This unmap did not refer to the full mapped memory. This caused a message to var/log/messages.

Comment 1 Doug Ledford 2011-08-08 16:55:35 UTC
Getting this in with the rest of the InfiniBand refresh would be preferable in my opinion.

Comment 5 Honggang LI 2011-11-17 05:40:28 UTC
--------------------- verify ---------------------------------------

[root@rdma1 ~]# uname -a
Linux rdma1.rhts.eng.bos.redhat.com 2.6.32-220.el6.x86_64 #1 SMP Wed Nov 9 08:03:13 EST 2011 x86_64 x86_64 x86_64 GNU/Linux

[root@rdma1 ~]# rpm -q mstflint
mstflint-1.4-5.el6.x86_64

[root@rdma1 ~]# lspci | grep Mellanox
06:00.0 InfiniBand: Mellanox Technologies MT25418 [ConnectX VPI PCIe 2.0 2.5GT/s - IB DDR / 10GigE] (rev a0)

[root@rdma1 ~]# mstflint -d 06:00.0 q
Image type:      ConnectX
FW Version:      2.6.0
Device ID:       25418
Description:     Node             Port1            Port2            Sys image
GUIDs:           0002c9030000adc0 0002c9030000adc1 0002c9030000adc2 0002c9030000adc3 
MACs:                                 00fbc43b3c01     00fbc43b3c02
Board ID:         (MT_04A0120002)
VSD:             
PSID:            MT_04A0120002

-------------------------------------------------------------
No garbage. Set it as verified.

Comment 6 errata-xmlrpc 2011-12-06 15:33:40 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2011-1639.html


Note You need to log in before you can comment on or make changes to this bug.