Bug 729063 - RFE: include hostname in matahari-hostd heartbeat event
Summary: RFE: include hostname in matahari-hostd heartbeat event
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: matahari
Version: 6.2
Hardware: Unspecified
OS: Unspecified
unspecified
low
Target Milestone: rc
: ---
Assignee: Andrew Beekhof
QA Contact: Dave Johnson
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-08-08 16:05 UTC by Dave Johnson
Modified: 2016-04-26 14:46 UTC (History)
3 users (show)

Fixed In Version: matahari-0.4.2-4.el6
Doc Type: Enhancement
Doc Text:
Cause: The Host agent produces heartbeat events, but previously included only time related meta data. Consequence: It was in some ways difficult to associate heartbeat events with the host they originated from. This was primarily the case in logs. Change: The heatbeat events produced by the Host agent now include the hostname and the hardware UUID as additional meta data. Result: It is easier to associate the Host agent heartbeat events with the host they originated from.
Clone Of:
Environment:
Last Closed: 2011-12-06 11:39:32 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2011:1569 normal SHIPPED_LIVE matahari bug fix and enhancement update 2011-12-06 00:39:06 UTC

Description Dave Johnson 2011-08-08 16:05:34 UTC
Description of problem:
Couldn't the hostname be included in a heartbeat event from to help distinguish between events? 

Mon Aug  8 15:57:21 2011 INFO  org.matahariproject:heartbeat broker=localhost:49000 timestamp=1312819041 sequence=40
Mon Aug  8 15:57:22 2011 INFO  org.matahariproject:heartbeat broker=localhost:49000 timestamp=1312819042 sequence=588


Version-Release number of selected component (if applicable):
matahari-host-0.4.2-2.el6.x86_64

How reproducible:
100%

Steps to Reproduce:
1.  Install an local matahari broker and host agent on serverA
2.  Start broker and agent on serverA
3.  run qpid-printevents on serverA, see heartbeat event from local host agent
4.  Install host agent on serverB
5.  configure host agent on serverB to connect to broker @ serverA
6.  start host agent on serverB
7.  see new heartbeat events in qpid-printevents from step 3, no way to distinguish between the events (besides the sequence which really will not work after running any amount of time)

Comment 2 Andrew Beekhof 2011-08-08 19:40:33 UTC
Hardware UUID too

Comment 3 Andrew Beekhof 2011-08-09 02:33:59 UTC
A related patch has been committed upstream: https://github.com/beekhof/matahari/commit/bfa436e

Comment 5 Dave Johnson 2011-08-16 23:08:26 UTC
good 2 go in v0.4.2-6

Comment 6 Russell Bryant 2011-11-16 21:35:05 UTC
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
Cause: The Host agent produces heartbeat events, but previously included only time related meta data.
Consequence: It was in some ways difficult to associate heartbeat events with the host they originated from.  This was primarily the case in logs.
Change: The heatbeat events produced by the Host agent now include the hostname and the hardware UUID as additional meta data.
Result: It is easier to associate the Host agent heartbeat events with the host they originated from.

Comment 7 errata-xmlrpc 2011-12-06 11:39:32 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2011-1569.html


Note You need to log in before you can comment on or make changes to this bug.