Bug 729068 - kadmin incompatible with kdc
Summary: kadmin incompatible with kdc
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: krb5
Version: 6.1
Hardware: All
OS: Linux
medium
medium
Target Milestone: rc
: ---
Assignee: Nalin Dahyabhai
QA Contact: BaseOS QE Security Team
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-08-08 16:28 UTC by Jarrod Makin
Modified: 2011-12-06 17:37 UTC (History)
3 users (show)

Fixed In Version: krb5-1.9-11.el6
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-12-06 17:37:08 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2011:1707 normal SHIPPED_LIVE krb5 bug fix update 2011-12-06 01:02:29 UTC
Red Hat Bugzilla 713252 None None None Never

Description Jarrod Makin 2011-08-08 16:28:43 UTC
Description of problem:

I have an RHEL4 box as my KDC and an RHEL6.1 server attempting to connect.

[root@rhel6box ~]# kadmin -p user/admin
Authenticating as principal user/admin with password.
Password for user/admin@DOMAIN.CO.UK:
kadmin: GSS-API (or Kerberos) error while initializing kadmin interface

on the RHEL4 box, the following is logged in /var/log/kadmind.log

... kadmind[31449](Notice): Authentication attempt failed: 10.0.1.4, GSS-API error strings are:
... kadmind[31449](Notice): Authentication attempt failed: 10.0.1.4, GSS-API error strings are:
... kadmind[31449](Notice):     Incorrect channel bindings were supplied
... kadmind[31449](Notice):     Incorrect channel bindings were supplied
... kadmind[31449](Notice):     No error
... kadmind[31449](Notice):     No error
... kadmind[31449](Notice):    GSS-API error strings complete.
... kadmind[31449](Notice):    GSS-API error strings complete.


rpms installed are:
krb5-libs-1.9-9.el6_1.1.x86_64
krb5-workstation-1.9-9.el6_1.1.x86_64

my current workaround is to downgrade to
krb5-libs-1.8.2-3.el6_0.7.x86_64
krb5-workstation-1.8.2-3.el6_0.7.x86_64

Comment 6 errata-xmlrpc 2011-12-06 17:37:08 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2011-1707.html


Note You need to log in before you can comment on or make changes to this bug.