Bug 729131 - JCA Adaptor Install & Users Guide
Summary: JCA Adaptor Install & Users Guide
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Enterprise MRG
Classification: Red Hat
Component: Documentation
Version: 2.0
Hardware: All
OS: All
high
high
Target Milestone: 2.1.2
: ---
Assignee: Cheryn Tan
QA Contact: ppecka
URL:
Whiteboard:
: 716815 (view as bug list)
Depends On: 737444
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-08-08 19:36 UTC by Irina Boverman
Modified: 2014-06-18 07:51 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-05-02 05:31:02 UTC


Attachments (Terms of Use)
General README file for the QPID JCA adapter. (10.17 KB, text/plain)
2011-08-22 11:32 UTC, Weston M. Price
no flags Details
README-JBOSS.txt provides EAP 5.x specific configuration options for the Qpid JCA Adapter (7.93 KB, text/plain)
2011-08-23 12:50 UTC, Weston M. Price
no flags Details
reviewed General README (9.86 KB, text/plain)
2011-09-29 06:27 UTC, Alison Young
no flags Details
reviewed README-JBOSS provides EAP 5.x specific configuration options for the Qpid JCA Adapter (7.86 KB, text/plain)
2011-09-29 06:28 UTC, Alison Young
no flags Details

Description Irina Boverman 2011-08-08 19:36:05 UTC
Description of problem:

Need new document that will explain how to Install, Configure and Use JCA Adaptor with EAP 5.


Additional info:
Engineering ("Weston M. Price" <wprice@redhat.com>) will provide information (README file).

Comment 2 Alison Young 2011-08-22 03:39:22 UTC
Hi Weston,

Can you provide the information about installation, configuration and use of JCA Adaptor with EAP 5 please?

Thanks,
Alison

Comment 3 Weston M. Price 2011-08-22 11:32:25 UTC
Created attachment 519264 [details]
General README file for the QPID JCA adapter.

General README file for the QPID JCA adapter.

Comment 4 Weston M. Price 2011-08-22 11:33:00 UTC
Hi Allison,
  Sorry for the delay, I should have done this on Friday but it slipped my mind.

Regards,

Weston

Comment 5 Alison Young 2011-08-23 03:30:26 UTC
Thanks Weston.

Comment 6 Weston M. Price 2011-08-23 12:50:48 UTC
Created attachment 519454 [details]
README-JBOSS.txt provides EAP 5.x specific configuration options for the Qpid JCA Adapter

README-JBOSS.txt provides EAP 5.x specific configuration options for the Qpid JCA Adapter

Comment 7 Weston M. Price 2011-08-23 12:51:38 UTC
Hi Allison,
   I have also attached README-JBOSS.txt. While the general README.txt file provides most information
about the JCA adapter, this file is EAP 5.x specific.

Comment 8 Alison Young 2011-08-24 01:17:20 UTC
Great, thank-you again Weston.

Comment 9 Alison Young 2011-09-13 03:40:34 UTC
*** Bug 716815 has been marked as a duplicate of this bug. ***

Comment 12 Alison Young 2011-09-29 06:27:27 UTC
Created attachment 525460 [details]
reviewed General README

Comment 13 Alison Young 2011-09-29 06:28:43 UTC
Created attachment 525462 [details]
reviewed README-JBOSS provides EAP 5.x specific configuration options for the Qpid JCA Adapter

Comment 14 Jiri Pechanec 2011-09-29 14:41:43 UTC
README-JBOSS review
<ra-version> property is introduced in example for QpidJMSXA configuration. The rest of samples uses hardoced value 0.10
Admininstered Object Configuration shows the old configuration syntax. The new configration syntax, e.g.
<attribute name="Properties">
destinationAddress=jms_ee_mdb_mdb_sndQ_MDB_QUEUE;{create:always,node:{type:queue}}
destinationType=queue
</attribute>
is not documented
Limitations of external qpid connection factory are not documented

Cosmetic
the log message is 'Qpid resource adaptor started' not 'Qpid resource adapter started'

Comment 15 Jiri Pechanec 2011-09-29 14:59:25 UTC
README review
ra.xml contains properties named UserName and Password, the ddocumentation contains DefaultUserName and DefaultPassword

Comment 16 Lana Brindley 2011-10-13 01:52:06 UTC
This book is to be completed by Cheryn Tan, with an expected delivery date of 8 December, 2011. Cheryn will be using the content available in this ticket to create the book.

For documentation queries on this book, please contact me directly.

LKB

Comment 19 ppecka 2011-11-24 10:34:33 UTC
i would like to see rpm package which ships JCA (qpid-java-jca) to be noted somewhere in 
Messaging_Installation_Guide and/or Qpid_JCA_Adapter_User_Guide as it's part of Optional Packages.

Comment 20 Cheryn Tan 2011-11-28 02:08:04 UTC
(In reply to comment #19)
> i would like to see rpm package which ships JCA (qpid-java-jca) to be noted
> somewhere in 
> Messaging_Installation_Guide and/or Qpid_JCA_Adapter_User_Guide as it's part of
> Optional Packages.

Sorry ppecka, we can't make any more changes to the guides as the deadline for tech review was 18 November. Please open bugs for the relevant guides for the next release. Thank you.

Comment 21 ppecka 2011-12-01 12:10:38 UTC
Found couple of minor issues and rised BZ's against them to be solved in future releases.

--> VERIFIED

Comment 22 Cheryn Tan 2012-05-02 05:31:02 UTC
Documents have been published on http://docs.redhat.com/docs/en-US/Red_Hat_Enterprise_MRG/index.html as part of the MRG-M 2.1.2 update.


Note You need to log in before you can comment on or make changes to this bug.