Bug 729137 - SELinux is preventing /usr/bin/perl from 'setattr' accesses on the sock_file munin-master-processmanager-20902.sock.
Summary: SELinux is preventing /usr/bin/perl from 'setattr' accesses on the sock_file ...
Keywords:
Status: CLOSED DUPLICATE of bug 729135
Alias: None
Product: Fedora
Classification: Fedora
Component: selinux-policy
Version: 15
Hardware: x86_64
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Miroslav Grepl
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: setroubleshoot_trace_hash:ddd2ddade14...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-08-08 19:43 UTC by Till Maas
Modified: 2011-08-09 17:54 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-08-09 17:54:17 UTC


Attachments (Terms of Use)

Description Till Maas 2011-08-08 19:43:37 UTC
SELinux is preventing /usr/bin/perl from 'setattr' accesses on the sock_file munin-master-processmanager-20902.sock.

*****  Plugin catchall (100. confidence) suggests  ***************************

If you believe that perl should be allowed setattr access on the munin-master-processmanager-20902.sock sock_file by default.
Then you should report this as a bug.
You can generate a local policy module to allow this access.
Do
allow this access for now by executing:
# grep munin-update /var/log/audit/audit.log | audit2allow -M mypol
# semodule -i mypol.pp

Additional Information:
Source Context                system_u:system_r:munin_t:s0-s0:c0.c1023
Target Context                system_u:object_r:var_run_t:s0
Target Objects                munin-master-processmanager-20902.sock [ sock_file
                              ]
Source                        munin-update
Source Path                   /usr/bin/perl
Port                          <Unbekannt>
Host                          (removed)
Source RPM Packages           perl-5.12.4-159.fc15
Target RPM Packages           
Policy RPM                    selinux-policy-3.9.16-35.fc15
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Permissive
Host Name                     (removed)
Platform                      Linux (removed) 2.6.40-4.fc15.x86_64 #1 SMP
                              Fri Jul 29 18:46:53 UTC 2011 x86_64 x86_64
Alert Count                   1095
First Seen                    Do 04 Aug 2011 08:15:02 CEST
Last Seen                     Mo 08 Aug 2011 21:40:02 CEST
Local ID                      78324a74-01a5-458d-bfef-22515dd0a5c8

Raw Audit Messages
type=AVC msg=audit(1312832402.187:2915): avc:  denied  { setattr } for  pid=20902 comm="munin-update" name="munin-master-processmanager-20902.sock" dev=tmpfs ino=895609 scontext=system_u:system_r:munin_t:s0-s0:c0.c1023 tcontext=system_u:object_r:var_run_t:s0 tclass=sock_file


type=SYSCALL msg=audit(1312832402.187:2915): arch=x86_64 syscall=chmod success=yes exit=0 a0=300a670 a1=1c0 a2=4000 a3=0 items=0 ppid=20901 pid=20902 auid=487 uid=487 gid=470 euid=487 suid=487 fsuid=487 egid=470 sgid=470 fsgid=470 tty=(none) ses=309 comm=munin-update exe=/usr/bin/perl subj=system_u:system_r:munin_t:s0-s0:c0.c1023 key=(null)

Hash: munin-update,munin_t,var_run_t,sock_file,setattr

audit2allow

#============= munin_t ==============
allow munin_t var_run_t:sock_file setattr;

audit2allow -R

#============= munin_t ==============
allow munin_t var_run_t:sock_file setattr;

Comment 1 Daniel Walsh 2011-08-09 17:54:17 UTC

*** This bug has been marked as a duplicate of bug 729135 ***


Note You need to log in before you can comment on or make changes to this bug.