Bug 72915 - Bugs from Konsole -->vim
Bugs from Konsole -->vim
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: kdebase (Show other bugs)
7.3
i386 Linux
high Severity high
: ---
: ---
Assigned To: Ngo Than
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-08-28 19:51 EDT by Need Real Name
Modified: 2008-05-01 11:38 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-12-18 15:46:53 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2002-08-28 19:51:50 EDT
Description of Problem:    
in Konsole, start vim editor by "vi". If I close this vi(vim) session by   
clicking "Close Session" in Session dropdown menu, the vim process is not   
killed and is still running in background and use up all my memories. After 
I kill the vim process manually by "kill -9 1076". The system is back to 
normal. 
  
   
The attached is the information from "top":   
    
CPU states: 19.1% user, 80.8% system,  0.0% nice,  0.0% idle    
Mem:   191504K av,  131288K used,   60216K free,       0K shrd,    6652K buff    
Swap:  393112K av,       0K used,  393112K free                   65240K    
cached    
    
  PID USER     PRI  NI  SIZE  RSS SHARE STAT %CPU %MEM   TIME COMMAND    
 1076 root      25   0  2416 2416  1656 R    75.0  1.2   0:16 vim    
  949 root      15   0 11728  11M 10428 R    10.7  6.1   0:14 kdeinit    
    
  4:26pm  up 26 min,  3 users,  load average: 1.10, 0.60, 0.40    
51 processes: 47 sleeping, 4 running, 0 zombie, 0 stopped    
CPU states:  8.0% user, 91.9% system,  0.0% nice,  0.0% idle    
Mem:   191504K av,  131420K used,   60084K free,       0K shrd,    6780K buff    
Swap:  393112K av,       0K used,  393112K free                   65240K    
cached    
    
  PID USER     PRI  NI  SIZE  RSS SHARE STAT %CPU %MEM   TIME COMMAND    
 1076 root      25   0  2416 2416  1656 R    94.5  1.2   1:26 vim    
  949 root      15   0 11736  11M 10436 R     2.5  6.1   0:17 kdeinit    
  904 root      15   0 10740  10M  9724 S     1.9  5.6   0:23 kdeinit    
  986 root      15   0  1032 1032   828 R     0.9  0.5   0:11 top    
    
    
Version-Release number of selected component (if applicable):    
    
    
How Reproducible:    
    
    
Steps to Reproduce:    
1.  use kde   
2.  open Konsole   
3.  click New at bottom of Konsole to create shell No. 2  
4.  in first shell, type "top"  
5.  in shell No. 2, vi   
6.  close this vi(vim) session in shell No. 2 by  
    clicking "Close Session" in Session dropdown menu,  
    the vim process is not killed and is still running in  
    background and use up all my memories. 
    
Actual Results:    
    
    linux responses very slow since memories is used up to 95%. 
 
Expected Results:    
    
    
Additional Information:
Comment 1 Nakai 2002-08-29 01:13:33 EDT
Not kon2, but kdebase.
Comment 2 Ngo Than 2002-12-18 15:46:53 EST
It's fixed in kdebase-3.1-0.9 or newer.

Note You need to log in before you can comment on or make changes to this bug.