Bug 729150 - Regression: ignores From selection
Summary: Regression: ignores From selection
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: thunderbird
Version: 15
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ---
Assignee: Gecko Maintainer
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-08-08 20:39 UTC by Stas Sergeev
Modified: 2018-04-11 11:10 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-09-04 21:10:57 UTC


Attachments (Terms of Use)
screenshot of the editor sending (70.66 KB, image/png)
2011-09-04 20:31 UTC, Matěj Cepl
no flags Details
screenshot of the receiving message (257.87 KB, text/plain)
2011-09-04 20:32 UTC, Matěj Cepl
no flags Details

Description Stas Sergeev 2011-08-08 20:39:39 UTC
Description of problem:
If you have multiple "identities" for the single e-mail
account, you can choose one in an From: selection droplist.
Recently that stopped to produce the desired effect:
no matter what you choose in the mail composer, the
mail will be sent with the default identity.

Version-Release number of selected component (if applicable):
thunderbird-5.0-1.fc15.x86_64

How reproducible:
Always

Steps to Reproduce:
1. Use Edit->Account Settings->Manage Identities to add some
2. Click "Write" button, and in the composer choose the identity in the
From: droplist.
3. Click "Save" button
4. Check that saved mail in drafts
  
Actual results:
The default identity is used

Expected results:
Chosen identity is used

Additional info:
Very recent and serious regression!

Comment 1 Matěj Cepl 2011-09-04 20:31:03 UTC
Created attachment 521399 [details]
screenshot of the editor sending

Comment 2 Matěj Cepl 2011-09-04 20:32:19 UTC
Created attachment 521400 [details]
screenshot of the receiving message

Comment 3 Matěj Cepl 2011-09-04 20:34:31 UTC
Thanks for the bug report.  We have reviewed the information you have provided above, and there is some additional information we require that will be helpful in our diagnosis of this issue.

I cannot reproduce here with thunderbird-6.0-3.fc16.x86_64 (see the attached screenshots). So, we need more information to be able to reproduce the issue here.

1) Are you able to reproduce this when running thunderbird in the safe mode (i.e., run it with parameter -safe-mode on the command line)
2) Are you able to reproduce the problem with the upstream binary from
http://www.mozillamessaging.com/?
3) Are you able to reproduce the problem with a fresh profile?

Thank you for your cooperation and helping to make Fedora more awesome!

We will review this issue again once you've had a chance to attach this information.

Thanks in advance.

Comment 4 Stas Sergeev 2011-09-04 21:10:57 UTC
Seems to have been fixed already.


Note You need to log in before you can comment on or make changes to this bug.