Bug 729160 - Backport dm-snapshot cache flush
Summary: Backport dm-snapshot cache flush
Keywords:
Status: CLOSED DUPLICATE of bug 723005
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: kernel
Version: 6.1
Hardware: Unspecified
OS: Linux
high
high
Target Milestone: rc
: ---
Assignee: Red Hat Kernel Manager
QA Contact: Red Hat Kernel QE team
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-08-08 21:32 UTC by Mikuláš Patočka
Modified: 2011-08-08 22:18 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-08-08 22:18:19 UTC
Target Upstream Version:


Attachments (Terms of Use)
Patch ported from upstream (793 bytes, patch)
2011-08-08 21:32 UTC, Mikuláš Patočka
no flags Details | Diff

Description Mikuláš Patočka 2011-08-08 21:32:36 UTC
Created attachment 517312 [details]
Patch ported from upstream

Backport upstream patch 762a80d9fc9f690a3a35983f3b4619a220650808

This patch flushes hardware disk cache when merging a snapshot. Without the patch, writes may be reordered and data corruption is possible in case of power failure.

Comment 1 RHEL Product and Program Management 2011-08-08 21:40:39 UTC
This request was evaluated by Red Hat Product Management for inclusion
in a Red Hat Enterprise Linux maintenance release. Product Management has 
requested further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed 
products. This request is not yet committed for inclusion in an Update release.

Comment 2 Mike Snitzer 2011-08-08 22:18:19 UTC

*** This bug has been marked as a duplicate of bug 723005 ***


Note You need to log in before you can comment on or make changes to this bug.