Bug 729171 - yum update syslog-ng fails
Summary: yum update syslog-ng fails
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora EPEL
Classification: Fedora
Component: syslog-ng
Version: el6
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Jose Pedro Oliveira
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-08-08 22:09 UTC by Soichi Hayashi
Modified: 2011-08-09 22:15 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-08-09 22:15:20 UTC


Attachments (Terms of Use)

Description Soichi Hayashi 2011-08-08 22:09:17 UTC
When I tried to update syslog-ng, I ended up getting following error message.

Transaction Check Error:
  file /etc/init.d/syslog-ng from install of syslog-ng-2.1.4-9.el5.x86_64 conflicts with file from package syslog-ng-2.0.9-4.el5.i386
  file /etc/logrotate.d/syslog from install of syslog-ng-2.1.4-9.el5.x86_64 conflicts with file from package syslog-ng-2.0.9-4.el5.i386

I had to do following to resolve this issue.

rpm -e --nodeps syslog-ng
yum install syslog-ng


2011-08-08 22:07:35 UTC [root@is-dev:/opt/install/is]# cat /etc/issue
Red Hat Enterprise Linux Server release 5.7 (Tikanga)

2011-08-08 22:08:55 UTC [root@is-dev:/opt/install/is]# uname -a
Linux is-dev.grid.iu.edu 2.6.18-274.el5 #1 SMP Fri Jul 8 17:36:59 EDT 2011 x86_64 x86_64 x86_64 GNU/Linux

Comment 1 Jose Pedro Oliveira 2011-08-08 22:53:09 UTC
I believe you have installed, or you were trying to install, both the 32 and 64 bits version of syslog-ng (syslog-ng-2.1.4-9.el5.x86_64 vs syslog-ng-2.0.9-4.el5.i386).

Could you check that you have only one arch of syslog-ng installed? And the one installed matched your kernel arch? (rpm -q syslog-ng; uname -a).

/jpo

Comment 2 Soichi Hayashi 2011-08-09 20:21:06 UTC
I am not sure why 32 bit version of syslog-ng was installed, and I don't know why yum update all the sudden started to upgrade it to 64bit version. 

The real problem is that, I should be able to upgrade from 32bit to 64bit. One of our colleague has suggested that syslog-ng rpm spec file updated to include multilib parameters (http://fedoraproject.org/wiki/PackagingDrafts/MultilibTricks) 

We've always run "yum update" without this issue, and I believe having conflicting RPM in our machine was the trigger to this issue, not the cause itself.

Soichi

Comment 3 Jose Pedro Oliveira 2011-08-09 22:01:54 UTC
Soichi,

(In reply to comment #2)
> ...
> The real problem is that, I should be able to upgrade from 32bit to 64bit.
> ...

I don't believe this kind of migration is even recommended or supported by Red Hat
(at least I never come across a Red Hat document detailing the procedure).

Also, be advised that syslog-ng 2.1.4 is no longer supported by upstream.

Regards,
jpo

Comment 4 Jose Pedro Oliveira 2011-08-09 22:15:20 UTC
(In reply to comment #2)
> ... One
> of our colleague has suggested that syslog-ng rpm spec file updated to include
> multilib parameters
> (http://fedoraproject.org/wiki/PackagingDrafts/MultilibTricks) 

May I ask why would you want to run a 32-bit version of syslog-ng in a 64-bit system?


Note You need to log in before you can comment on or make changes to this bug.