Bug 729226 - Can not add a storage pool: rhel6 gtk doesn't have get_sensitive
Summary: Can not add a storage pool: rhel6 gtk doesn't have get_sensitive
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: virt-manager
Version: 6.2
Hardware: x86_64
OS: Linux
medium
high
Target Milestone: rc
: ---
Assignee: Cole Robinson
QA Contact: Virtualization Bugs
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-08-09 05:59 UTC by zhpeng
Modified: 2013-09-09 00:03 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
No description necessary
Clone Of:
Environment:
Last Closed: 2011-12-06 16:15:19 UTC


Attachments (Terms of Use)
debug info of virt-manager add pool (1.57 KB, text/plain)
2011-08-09 05:59 UTC, zhpeng
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2011:1642 normal SHIPPED_LIVE virt-manager bug fix and enhancement update 2011-12-06 00:50:37 UTC

Description zhpeng 2011-08-09 05:59:53 UTC
Created attachment 517348 [details]
debug info of virt-manager add pool

Description of problem:
when use virt-manager add a storage pool, an error dialog popup

Version-Release number of selected component (if applicable):
virt-manager-0.9.0-5.el6.x86_64
libvirt-0.9.4-1.el6.x86_64
qemu-kvm-0.12.1.2-2.175.el6.x86_64
kernel-2.6.32-175.el6.x86_64

How reproducible:
always

Steps to Reproduce:
1.open virt-manager, select "edit"  "connection details"  "storage"
2.click "+" to add a pool, for example "Type: dir:Filesystem Directory", insert pool name.click Forward
3.insert pool path,click Finish
virt-manager will crash at once or in a minute when you do other operations.


Actual results:
An error dialog popup. Add pool fail.
shows:
Traceback (most recent call last):
  File "/usr/share/virt-manager/virtManager/createpool.py", line 433, in forward
    if(self.validate(notebook.get_current_page()) != True):
  File "/usr/share/virt-manager/virtManager/createpool.py", line 534, in validate
    iqn     = self.get_config_iqn()
  File "/usr/share/virt-manager/virtManager/createpool.py", line 394, in get_config_iqn
    if iqn.get_sensitive() and iqn.get_property("visible"):
AttributeError: 'gtk.Entry' object has no attribute 'get_sensitive'


Expected results:
1.Add pool successfully. no error popup.

Additional info:

Comment 5 Cole Robinson 2011-08-30 19:38:17 UTC
Fixed in virt-manager-0.9.0-6.el6

Comment 7 zhe peng 2011-09-01 07:19:19 UTC
this bug can reproduce with virt-manager-0.9.0-5.el6
verify with:
libvirt-0.9.4-6.el6
qemu-kvm-0.12.1.2-2.184.el6
kernel-2.6.32-191.el6
virt-manager-0.9.0-6.el6
python-virtinst-0.600.0-3.el6

1.open virt-manager, select "edit"  "connection details"  "storage"
2.click "+" to add a pool, for example "Type: dir:Filesystem Directory", insert
pool name.click Forward
3.insert pool path,click Finish

the pool will be created succeeded. no error in debug info.
verification passed.

Comment 8 Cole Robinson 2011-11-07 16:42:09 UTC
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
No description necessary

Comment 9 errata-xmlrpc 2011-12-06 16:15:19 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2011-1642.html


Note You need to log in before you can comment on or make changes to this bug.