Bug 72924 - groff assertion fails in UTF-8 locale
Summary: groff assertion fails in UTF-8 locale
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Public Beta
Classification: Retired
Component: groff   
(Show other bugs)
Version: null
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Florian La Roche
QA Contact: Mike McLean
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: 67218
TreeView+ depends on / blocked
 
Reported: 2002-08-29 02:40 UTC by Scott Lamb
Modified: 2007-04-18 16:46 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-08-31 20:47:34 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Scott Lamb 2002-08-29 02:40:58 UTC
groff blows an assertion when passed the iso-8859-1 manual page with default
(UTF-8) locale.

    $ rpm -q man man-pages groff
    man-1.5j-9
    man-pages-1.53-1
    groff-1.18-5
    $ man 7 iso-8859-1 > /dev/null
    troff: Failed assertion at line 2996, file `node.cc'.
    groff: troff: Aborted
    grotty:<standard input>:543:warning: no final `x stop' command

Comment 1 Florian La Roche 2002-08-31 20:47:28 UTC
"man 7 iso_8859-1" works fine
"man 7 iso-8859-1" faults, but this is just a reference to the other man-page

"nroff -man -Tutf8 iso_8859-1.7 | less" and
"nroff -man -Tutf8 iso-8859-1.7 | less" work both fine and also without
the -Tutf8

Seems to be some problem with "man" or something else??

greetings,

Florian La Roche


Comment 2 Florian La Roche 2002-08-31 21:43:40 UTC
Fixed with release 6 or newer.

Thanks a lot,

Florian La Roche



Note You need to log in before you can comment on or make changes to this bug.