Bug 729267 - Netbeans 7.0 on fedora 15 is barely usable since recent openjdk update
Summary: Netbeans 7.0 on fedora 15 is barely usable since recent openjdk update
Keywords:
Status: CLOSED WORKSFORME
Alias: None
Product: Fedora
Classification: Fedora
Component: java-1.6.0-openjdk
Version: 15
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Deepak Bhole
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-08-09 10:13 UTC by fred
Modified: 2011-08-23 12:35 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-08-23 12:35:05 UTC


Attachments (Terms of Use)

Description fred 2011-08-09 10:13:32 UTC
Description of problem:
I'm using the stock netbeans 7. It used to work fine before a recent openjdk update.
When an action intends to close a window, the window do not close instead, and an NullPointer notification appears at the bottom right of the IDE. When possible, clicking three times on the button which should close the window actually closes it. However, the window that should close automatically, such as progress bars, do not close, and since they are modal, the IDE is unusable.


Version-Release number of selected component (if applicable):
THe problems appeared recently (last week), since the last jdk update I think:
java-1.6.0-openjdk-59.1.10.3.fc15


How reproducible:
Everytime

Steps to Reproduce:
1- Open netbeans 
2- open a projet: uses a modal progress bar which never closes
OR
1- have an already opened versionned project
2- Try to commit a file. First click actually commits but do not close the window. Second click do nothing. Third click closes the window.
  
Expected results:
opening projects should work. Windows should close as expected


Additional info:
stack:
http://statistics.netbeans.org/analytics/exception.do?id=523037
duplicates:
http://statistics.netbeans.org/analytics/detail.do?id=150039
And (maybe) an analysis from the netbeans guys:
https://netbeans.org/bugzilla/show_bug.cgi?id=163548

Comment 1 fred 2011-08-23 12:34:37 UTC
the bug seems to have been fixed by a recent update.


Note You need to log in before you can comment on or make changes to this bug.