Bug 729324 - host installation failed - vds_bootstrap imports utils from yum [for RHEL 5.8 / VDSM 2.2.x]
Summary: host installation failed - vds_bootstrap imports utils from yum [for RHEL 5....
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: vdsm22
Version: 5.7
Hardware: All
OS: Linux
urgent
urgent
Target Milestone: rc
: ---
Assignee: Dan Kenigsberg
QA Contact: yeylon@redhat.com
URL:
Whiteboard:
Depends On: 726643
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-08-09 14:09 UTC by Chris Pelland
Modified: 2016-04-18 06:41 UTC (History)
14 users (show)

Fixed In Version: vdsm22-4.5-66.el5_7
Doc Type: Bug Fix
Doc Text:
Attaching a Red Hat Enterprise Linux 5.7 host to a Red Hat Enterprise Virtualization manager failed because when the bootstrap process imported the utilities, installing utils from yum overwrote the VDSM directory from the current Python path. The VDSM directory is now added to the current Python path so you can attach the 5.7 host successfully.
Clone Of:
Environment:
Last Closed: 2011-09-06 09:28:45 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2011:1213 normal SHIPPED_LIVE vdsm bug fix & enhancement update 2011-09-06 09:28:15 UTC

Description Chris Pelland 2011-08-09 14:09:27 UTC
This bug has been copied from bug #726643 and has been proposed
to be backported to 5.7 z-stream (EUS).

Comment 6 Daniel Paikov 2011-08-10 13:55:10 UTC
This doesn't reproduce for me either before or after the fix (4.5-63 vs. 4.5-66), as long as the RHEVM has a working bootstrap. What's to test here?

Comment 7 Dan Kenigsberg 2011-08-11 08:28:27 UTC
The bug lay within the code creating a new rhevm bridge. Did you try this on a fresh host, with no /etc/vdsm/vdsm.conf and no bridge?

Comment 8 Daniel Paikov 2011-08-11 08:36:01 UTC
Yes, and I had no bridge problem. But what the host received from the repo was 4.5-63, because 4.5-66 isn't on the repo yet.

Comment 9 Daniel Paikov 2011-08-14 10:15:43 UTC
Checked on 4.5-67.

Comment 10 Kate Grainger 2011-08-24 07:36:41 UTC
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
Attaching a Red Hat Enterprise Linux 5.7 host to a Red Hat Enterprise Virtualization manager failed because when the bootstrap process imported the utilities, installing utils from yum overwrote the VDSM directory from the current Python path. The VDSM directory is now added to the current Python path so you can attach the 5.7 host successfully.

Comment 11 errata-xmlrpc 2011-09-06 09:28:45 UTC
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2011-1213.html


Note You need to log in before you can comment on or make changes to this bug.